Skip to content

Commit

Permalink
dev-qt/qtwebengine: Update paxmark-mksnapshot patches for 5.11.{1,2}
Browse files Browse the repository at this point in the history
Reported-by: Han <[email protected]>
Thanks-to: Attila Tóth <[email protected]>
Thanks-to: Miroslaw Mieszczak <[email protected]>
Closes: https://bugs.gentoo.org/670852
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Nov 10, 2018
1 parent 5e32194 commit 07df47d
Show file tree
Hide file tree
Showing 4 changed files with 84 additions and 2 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
Bug: https://bugs.gentoo.org/634220

--- a/src/3rdparty/chromium/v8/BUILD.gn
+++ b/src/3rdparty/chromium/v8/BUILD.gn
@@ -661,6 +661,7 @@ action("run_mksnapshot") {

deps = [
":mksnapshot($v8_snapshot_toolchain)",
+ ":run_paxmark",
]

script = "tools/run.py"
@@ -706,6 +707,28 @@ action("run_mksnapshot") {
args += [ rebase_path(v8_embed_script, root_build_dir) ]
}
}
+action("run_paxmark") {
+ visibility = [ ":*" ] # Only targets in this file can depend on this.
+
+ deps = [
+ ":mksnapshot($v8_snapshot_toolchain)",
+ ]
+
+ script = "/usr/sbin/pypaxctl"
+
+ sources = []
+
+ outputs = [
+ "$target_out_dir/mksnapshot",
+ ]
+
+ args = [
+ "-sm",
+ "./" + rebase_path(get_label_info(":mksnapshot($v8_snapshot_toolchain)",
+ "root_out_dir") + "/mksnapshot",
+ root_build_dir),
+ ]
+}

action("run_mkpeephole") {
visibility = [ ":*" ] # Only targets in this file can depend on this.
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
Bug: https://bugs.gentoo.org/634220

--- a/src/3rdparty/chromium/v8/BUILD.gn
+++ b/src/3rdparty/chromium/v8/BUILD.gn
@@ -803,6 +803,7 @@

deps = [
":mksnapshot($v8_snapshot_toolchain)",
+ ":run_paxmark",
]

script = "tools/run.py"
@@ -854,6 +855,28 @@
}
}
}
+action("run_paxmark") {
+ visibility = [ ":*" ] # Only targets in this file can depend on this.
+
+ deps = [
+ ":mksnapshot($v8_snapshot_toolchain)",
+ ]
+
+ script = "/usr/sbin/pypaxctl"
+
+ sources = []
+
+ outputs = [
+ "$target_out_dir/mksnapshot",
+ ]
+
+ args = [
+ "-sm",
+ "./" + rebase_path(get_label_info(":mksnapshot($v8_snapshot_toolchain)",
+ "root_out_dir") + "/mksnapshot",
+ root_build_dir),
+ ]
+}

action("v8_dump_build_config") {
script = "tools/testrunner/utils/dump_build_config.py"
2 changes: 1 addition & 1 deletion dev-qt/qtwebengine/qtwebengine-5.11.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -86,7 +86,7 @@ PATCHES+=(
)

src_prepare() {
use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.9.3-paxmark-mksnapshot.patch" )
use pax_kernel && PATCHES+=( "${FILESDIR}/${P}-paxmark-mksnapshot.patch" )

# bug 620444 - ensure local headers are used
find "${S}" -type f -name "*.pr[fio]" | xargs sed -i -e 's|INCLUDEPATH += |&$$QTWEBENGINE_ROOT/include |' || die
Expand Down
2 changes: 1 addition & 1 deletion dev-qt/qtwebengine/qtwebengine-5.11.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -84,7 +84,7 @@ PATCHES+=(
)

src_prepare() {
use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.9.3-paxmark-mksnapshot.patch" )
use pax_kernel && PATCHES+=( "${FILESDIR}/${P}-paxmark-mksnapshot.patch" )

if ! use jumbo-build; then
sed -i -e 's|use_jumbo_build=true|use_jumbo_build=false|' \
Expand Down

0 comments on commit 07df47d

Please sign in to comment.