Skip to content

Commit

Permalink
gnome-extra/gnome-boxes: add gnome-boxes-3.22.2.ebuild
Browse files Browse the repository at this point in the history
Simple bump, as no relevant changes

https://git.gnome.org/browse/gnome-boxes/diff/?id=v3.22.2&&id2=v3.22.1
Closes: gentoo#2784

Signed-off-by: Gilles Dartiguelongue <[email protected]>
  • Loading branch information
kobboi authored and EvaSDK committed Nov 9, 2016
1 parent 87352e6 commit 0853d25
Show file tree
Hide file tree
Showing 2 changed files with 109 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/gnome-boxes/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gnome-boxes-3.20.2.tar.xz 1686172 SHA256 c0379ce1de9d2a43a6875cbe1f2ef7ef69161b284926d59c44246a9142130fc5 SHA512 3ead46d8b65777e43bf55b04b9488a1a8c5d4a0bc46f582a46ae2d5ff883c01b5540739091c2f3065d3db666d38761dee6dacbde9d5c9042f5b79f1ad4769247 WHIRLPOOL 6545ae607965d51bea04335acb4050ccc606f764cb12e3a44a670007bd7d2387ca69f59539877ebce6ea8357dfcde6d6d786d2effac691f4ee1e8021a1ca64df
DIST gnome-boxes-3.22.1.tar.xz 1737956 SHA256 be807d9336e96af6dea8f269a4b6dbbd3e9bb5fd135efc952aa2d62dde87b8ea SHA512 c5833e2af4977280c00b242a7b6703a5e7c58c59680aba793f3f6ec060676a6a542f29889fa5f48e4ba19792a7594e48d54a00d140b6be4ac3fa641dd6330d12 WHIRLPOOL 0b121af5375e9ea58f72c5e9db7eb6852f245ec2406a5751c1f5eee25b1e4aaade5478b8e40f6a418877d428b20a7f33b4e0ffcde4de52548c0988701e711662
DIST gnome-boxes-3.22.2.tar.xz 1699980 SHA256 559d79c061bb09e9000c3b06d677a7bd7c8fddf290cf935cd5ed78041261ed9a SHA512 fc49e4b4f0a9b2099b5a2f134e3e8de9df159cae71b2492d88d88567f4a47c5db657f12f775f5d0ea68148f489222e0262382c11d0315fcd1f9f293ce830b8a3 WHIRLPOOL 8158b0b4f74dc840bc8611acd66348843919d10af7e3ece161115980516c45a564fb8933436864e37a194cf120598735ffa7df23e87866ea1a85a96c7a3c1c5a
108 changes: 108 additions & 0 deletions gnome-extra/gnome-boxes/gnome-boxes-3.22.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,108 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
VALA_USE_DEPEND="vapigen"
VALA_MIN_API_VERSION="0.28"

inherit gnome2 linux-info readme.gentoo-r1 vala

DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"

LICENSE="LGPL-2"
SLOT="0"

# We force 'bindist' due to licenses from gnome-boxes-nonfree
IUSE="" #bindist

KEYWORDS="~amd64" # qemu-kvm[spice] is 64bit-only

# NOTE: sys-fs/* stuff is called via exec()
# FIXME: ovirt is not available in tree
# FIXME: use vala.eclass but only because of libgd not being able
# to use its pre-generated files so do not copy all the
# vala deps like live ebuild has.
# FIXME: qemu probably needs to depend on spice[smartcard]
# directly with USE=spice
RDEPEND="
>=app-arch/libarchive-3:=
>=dev-libs/glib-2.38:2
>=dev-libs/gobject-introspection-0.9.6:=
>=dev-libs/libxml2-2.7.8:2
>=sys-libs/libosinfo-0.2.12
>=app-emulation/qemu-1.3.1[spice,smartcard,usbredir]
>=app-emulation/libvirt-0.9.3[libvirtd,qemu]
>=app-emulation/libvirt-glib-0.2.3
>=x11-libs/gtk+-3.19.4:3
>=net-libs/gtk-vnc-0.4.4[gtk3]
app-emulation/spice[smartcard]
>=net-misc/spice-gtk-0.27[gtk3,smartcard,usbredir]
virtual/libusb:1
>=app-misc/tracker-0.16:0=[iso]
>=sys-apps/util-linux-2.20
>=net-libs/libsoup-2.38:2.4
sys-fs/fuse
sys-fs/fuseiso
sys-fs/mtools
>=virtual/libgudev-165:=
"
# !bindist? ( gnome-extra/gnome-boxes-nonfree )

DEPEND="${RDEPEND}
$(vala_depend)
app-text/yelp-tools
>=dev-util/intltool-0.40
>=sys-devel/gettext-0.17
virtual/pkgconfig
"

DISABLE_AUTOFORMATTING="yes"
DOC_CONTENTS="Before running gnome-boxes, you will need to load the KVM modules.
If you have an Intel Processor, run:
# modprobe kvm-intel
If you have an AMD Processor, run:
# modprobe kvm-amd"

pkg_pretend() {
linux-info_get_any_version

if linux_config_exists; then
if ! { linux_chkconfig_present KVM_AMD || \
linux_chkconfig_present KVM_INTEL; }; then
ewarn "You need KVM support in your kernel to use GNOME Boxes!"
fi
fi
}

src_prepare() {
# Do not change CFLAGS, wondering about VALA ones but appears to be
# needed as noted in configure comments below
sed 's/CFLAGS="$CFLAGS -O0 -ggdb3"//' -i configure{.ac,} || die

vala_src_prepare
gnome2_src_prepare
}

src_configure() {
# debug needed for splitdebug proper behavior (cardoe), bug #????
gnome2_src_configure \
--enable-debug \
--disable-strict-cc \
--disable-ovirt
}

src_install() {
gnome2_src_install
readme.gentoo_create_doc
}

pkg_postinst() {
gnome2_pkg_postinst
readme.gentoo_print_elog
}

0 comments on commit 0853d25

Please sign in to comment.