Skip to content

Commit

Permalink
app-arch/rar: Bump to v5.6.0 Beta 1 from 2018-03-11
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
Whissi committed Mar 11, 2018
1 parent cf094cc commit 090cdd4
Show file tree
Hide file tree
Showing 2 changed files with 112 additions and 0 deletions.
3 changes: 3 additions & 0 deletions app-arch/rar/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,6 @@
DIST rarlinux-5.5.0_p20170811.tar.gz 546839 BLAKE2B d90bda3092fb636fee1db4f222632cf3d45c99f330298521b2a0957cd7bd4845f4518cf394e03a4e302d45cf73a37f5da5ac0cd7eba08a4859fd221697656c20 SHA512 c437d0be55ea90ae1dd9d657517d17d9edbba07cd77325785d8d503883847edeece2cc3993d3beec3a5b36b6830383b7026fbfc53b18f490288395994bc532cb
DIST rarlinux-5.6.0_beta1_p20180311.tar.gz 551336 BLAKE2B d56bc53f729641cbf5cbc7b4abf9b3260e164e7cbf37e1faa227736456fff00d418699d05d628c5dfa0bf8517aa2c181a231e520e7c66c37288707808526d3d2 SHA512 9061ad96f8c933f942eb9e7d383a38b7056895ff542fdc26980f4d1140180f7a5c21ed288d4068edd0b25898645ff7977aad4b646882f5f8f57bbb8b89a40bd2
DIST rarlinux-x64-5.5.0_p20170811.tar.gz 536028 BLAKE2B be453cab6720abc4b01f5aef6c5874b0ff328656f8452b2a671b1b5305427dbb0de2af4084e25e972c69fe4ca4072b10f21d66f7fee23a3e205b0b4f533c8b7f SHA512 1ca8cf7fbe526b43bdc9aeeccb6a0d86efd3bbaeee554e807d58ab62857294abc89662bb42b17b2cfe7e6739876c6345455cd027abbc4cb84312c58314278a66
DIST rarlinux-x64-5.6.0_beta1_p20180311.tar.gz 540817 BLAKE2B 4ea8121df7dc57880cb148a8bf81c69b596011d3bfe462c90aaf9da4ce26d3fac1eb16324c55aaf79380f604493b9ecba1a1ed5ada76f76df1d9a1b97d522af3 SHA512 ca6624bdf55fe732a3aac18733b3ea35a519567474a49f549c27272a0107b60fa93ee16e0e49d5822d4fa33b11c355f67b047c42ed0393ef3a9d840eb8b4c783
DIST winrar-x64-5.5.0_p20170811.exe 2220872 BLAKE2B a37783f427440a5166021475f024ca6e281b4f0d39926e55c00588e51d371bdd1bd16bd04ed65c363f7aeef6d7e2b0ba796325f7f290e45cfd8c09048ae25489 SHA512 f2aa40bb875be7f88cd618b1f5e02cfe0c5fb584f4e27d06531aaee018e613a70be7b7d3e8b92448381dc83605db6bf044cbecc52f63b6045193fef07601be66
DIST winrar-x64-5.6.0_beta1_p20180311.exe 3186432 BLAKE2B 13063c52488f3a1e1d6a9f0b85761194d14feb549aede1c8653351cce8527794c88a37b177988328ac2293cf993848e1b0b4865a6f0adeef7c49a33a71f2f366 SHA512 2af5dabd88a0a70bdc2ffdbb1488e6b0b1c4cbe52d91bef86991c40b31fd8ef7482f47c134a13197798366eceee7ae6f8d39e0ef3660245ee89265cb65d43ffe
109 changes: 109 additions & 0 deletions app-arch/rar/rar-5.6.0_beta1_p20180311.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,109 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

DESCRIPTION="RAR compressor/uncompressor"
HOMEPAGE="http://www.rarsoft.com/"
URI_x86="https://mirror.whissi.de/distfiles/rar/rarlinux-${PV}.tar.gz"
URI_amd64="https://mirror.whissi.de/distfiles/rar/rarlinux-x64-${PV}.tar.gz"
URI_w64="https://mirror.whissi.de/distfiles/rar/winrar-x64-${PV}.exe"
SRC_URI="x86? ( ${URI_x86} )
amd64? ( ${URI_amd64} )
all_sfx? (
${URI_x86}
${URI_amd64}
${URI_w64}
)"

LICENSE="RAR BSD BSD-2"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="all_sfx"
RESTRICT="mirror bindist"

DEPEND="all_sfx? ( app-arch/unrar )"
RDEPEND="sys-libs/glibc"

S="${WORKDIR}/${PN}"

QA_FLAGS_IGNORED="opt/rar/default.sfx
opt/rar/default-elf32.sfx
opt/rar/default-elf64.sfx
opt/rar/default-win32.sfx
opt/rar/default-win64.sfx
opt/rar/WinCon.SFX
opt/rar/WinCon64.SFX
opt/rar/Zip.SFX
opt/rar/Zip64.SFX
opt/rar/unrar
opt/rar/rar"
QA_PRESTRIPPED=${QA_FLAGS_IGNORED}

src_unpack() {
local _file

for _file in ${A}; do
if [[ "${_file}" == rarli* ]]; then
if [[ "${_file}" =~ x64 ]]; then
if ! use amd64; then
continue
fi

unpack "${_file}"
elif [[ ! "${_file}" =~ x64 ]]; then
if ! use x86; then
continue
fi

unpack "${_file}"
else
die "Unknown SRC file '${_file}'!"
fi
fi
done

rm -f "${S}"/license.txt

if use all_sfx ; then
mkdir sfx
cd sfx
for _file in ${A}; do
if [[ "${_file}" == rarli* ]]; then
unpack "${_file}"
if [[ "${_file}" =~ x64 ]]; then
mv rar/default.sfx default-elf64.sfx || die
else
mv rar/default.sfx default-elf32.sfx || die
fi
elif [[ "${_file}" == winrar* ]]; then
ln -s "${DISTDIR}"/${_file} w64.rar || die
unpack ./w64.rar
mv Default.SFX default-win32.sfx || die
mv Default64.SFX default-win64.sfx || die
else
die "Unknown SFX file '${_file}'!"
fi
done
fi
}

src_compile() { :; }

src_install() {
exeinto /opt/rar
doexe rar unrar || die

dodir /opt/bin
dosym ../rar/rar /opt/bin/rar || die
dosym ../rar/unrar /opt/bin/unrar || die

insinto /opt/rar
if use all_sfx ; then
doins "${WORKDIR}"/sfx/*.{sfx,SFX} || die
else
doins default.sfx || die
fi
doins rarfiles.lst || die
dodoc *.txt
}

0 comments on commit 090cdd4

Please sign in to comment.