Skip to content

Commit

Permalink
games-kids/tuxmathscrabble: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Aug 5, 2016
1 parent 34d30a2 commit 093a489
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 4 deletions.
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- TuxMathScrabble/tms.py.old 2015-02-02 22:19:30.894373011 +0100
+++ TuxMathScrabble/tms.py 2015-02-02 22:20:19.530320947 +0100
--- a/TuxMathScrabble/tms.py 2015-02-02 22:19:30.894373011 +0100
+++ b/TuxMathScrabble/tms.py 2015-02-02 22:20:19.530320947 +0100
@@ -1258,7 +1258,7 @@
if not os.path.exists(infname):

Expand All @@ -9,8 +9,8 @@
if os.path.exists(candidate):
master_fname=candidate

--- .tms_config_master.old 2015-02-02 22:21:59.655216399 +0100
+++ .tms_config_master 2015-02-02 22:25:33.754003432 +0100
--- a/.tms_config_master 2015-02-02 22:21:59.655216399 +0100
+++ b/.tms_config_master 2015-02-02 22:25:33.754003432 +0100
@@ -380,66 +380,66 @@
'wtype':'wx.SpinCtrl',
},
Expand Down
65 changes: 65 additions & 0 deletions games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 )
inherit eutils python-single-r1 multilib

MY_PN=TuxMathScrabble
DESCRIPTION="math-version of the popular board game for children 4-10"
HOMEPAGE="http://www.asymptopia.org/"
SRC_URI="https://github.com/asymptopia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

CDEPEND="${PYTHON_DEPS}
dev-python/wxpython[${PYTHON_USEDEP}]"
DEPEND="${CDEPEND}
app-arch/unzip"
RDEPEND="${CDEPEND}
dev-python/pygame[${PYTHON_USEDEP}]"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

pkg_setup() {
python-single-r1_pkg_setup
}

PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
)

src_prepare() {
default

rm -f $(find . -name '*.pyc')
sed -i \
-e "s:@GENTOO_DATADIR@:/usr/share/${MY_PN}:" \
${MY_PN}/tms.py \
.tms_config_master \
|| die "sed failed"
sed -i \
-e "s:python2.7-32:python:g" \
${PN}.py || die "2nd sed failed"
python_fix_shebang .
}

src_install() {
newbin ${PN}.py ${PN}

insinto $(python_get_sitedir)
doins -r ${MY_PN}

insinto /usr/share/${MY_PN}
doins -r .tms_config_master Font

python_optimize

newicon tms.ico ${PN}.ico
make_desktop_entry ${PN} ${PN} /usr/share/pixmaps/${PN}.ico

dodoc CHANGES README
}

0 comments on commit 093a489

Please sign in to comment.