forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-kids/tuxmathscrabble: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
- Loading branch information
Showing
2 changed files
with
69 additions
and
4 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
65 changes: 65 additions & 0 deletions
65
games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,65 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 ) | ||
inherit eutils python-single-r1 multilib | ||
|
||
MY_PN=TuxMathScrabble | ||
DESCRIPTION="math-version of the popular board game for children 4-10" | ||
HOMEPAGE="http://www.asymptopia.org/" | ||
SRC_URI="https://github.com/asymptopia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="" | ||
|
||
CDEPEND="${PYTHON_DEPS} | ||
dev-python/wxpython[${PYTHON_USEDEP}]" | ||
DEPEND="${CDEPEND} | ||
app-arch/unzip" | ||
RDEPEND="${CDEPEND} | ||
dev-python/pygame[${PYTHON_USEDEP}]" | ||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
pkg_setup() { | ||
python-single-r1_pkg_setup | ||
} | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${P}-gentoo.patch | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
rm -f $(find . -name '*.pyc') | ||
sed -i \ | ||
-e "s:@GENTOO_DATADIR@:/usr/share/${MY_PN}:" \ | ||
${MY_PN}/tms.py \ | ||
.tms_config_master \ | ||
|| die "sed failed" | ||
sed -i \ | ||
-e "s:python2.7-32:python:g" \ | ||
${PN}.py || die "2nd sed failed" | ||
python_fix_shebang . | ||
} | ||
|
||
src_install() { | ||
newbin ${PN}.py ${PN} | ||
|
||
insinto $(python_get_sitedir) | ||
doins -r ${MY_PN} | ||
|
||
insinto /usr/share/${MY_PN} | ||
doins -r .tms_config_master Font | ||
|
||
python_optimize | ||
|
||
newicon tms.ico ${PN}.ico | ||
make_desktop_entry ${PN} ${PN} /usr/share/pixmaps/${PN}.ico | ||
|
||
dodoc CHANGES README | ||
} |