Skip to content

Commit

Permalink
mate-base/caja: Version bump to 1.14.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
mudler committed Nov 21, 2016
1 parent ec425b9 commit 0949042
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-base/caja/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST caja-1.10.4.tar.xz 3585224 SHA256 0294f6ab2017c84e5838bc3f01d3984a4cd6c9328f733a9a183238203f64555f SHA512 42b1daf015f588842e5a02bbb3ad4f0432d20c99cc702c02056a6cf6a97161fcbacf5dbdaf503d9ce029e107e1523666fae255887700d1f87e26b594f9546ecd WHIRLPOOL 2c46fafff948f724f692da1ccdb851dce5247f08c2be59a8d2d7ad25dceecdf37dafe500320b34bad150f3238b3e85157a558fa924f7a54ec5623bee8a232f7c
DIST caja-1.12.7.tar.xz 3645820 SHA256 94bd13a34a8a1ef725bb9d9de7f0db8da16e701fc5bcf5d2f1d39c7af18f42cf SHA512 32761370cc419ab8d8f815a291782d1ce380d04bf2450dbcea9d0f17d91a1c0b9a487a67a51a0c769a5fcb11091638a7b60e27b28f3148899ba44fb6feb313da WHIRLPOOL 373e24e548f620a7c5c48838d8660a298c021b3c49bda3d524b3bde9d70b012ef057752c3be3eec8c3a170f28da294fa1b000debe7a3cc1e45e3ffa0e881170b
DIST caja-1.14.2.tar.xz 3560252 SHA256 39a4d7ff1b71d1612d52cdc727ab13e34ec5960f532b406907b994cf99eebac6 SHA512 ef0c42e26fbeb2a2296c67fd0a1f59d18b104ba818761600dec2ab571fbd5a1d659471105b97a9fcd7b0e16afa1dfdf860decad1f65b299964017932f7dfdfbc WHIRLPOOL 56be105f1040a59c34d09d31998a8a60f8b17ad719c3efdfe3839c16296b5b239041f98da797f52c46fbcca61d55e374618a0f85c5155f3dbd9f0cfee485d2db
98 changes: 98 additions & 0 deletions mate-base/caja/caja-1.14.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

MATE_LA_PUNT="yes"

inherit mate virtualx

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~x86"
fi

DESCRIPTION="Caja file manager for the MATE desktop"
LICENSE="GPL-2 LGPL-2 FDL-1.1"
SLOT="0"

IUSE="gtk3 +introspection +mate packagekit xmp"

COMMON_DEPEND="dev-libs/atk:0
>=dev-libs/glib-2.36:2
>=dev-libs/libxml2-2.4.7:2
gnome-base/dconf:0
>=gnome-base/gvfs-1.10.1:0[udisks]
>=mate-base/mate-desktop-1.9:0[gtk3(-)=]
>=media-libs/libexif-0.6.14:0
x11-libs/cairo:0
x11-libs/gdk-pixbuf:2
x11-libs/libICE:0
x11-libs/libSM:0
x11-libs/libX11:0
x11-libs/libXext:0
x11-libs/libXft:0
x11-libs/libXrender:0
>=x11-libs/pango-1.1.2:0
virtual/libintl:0
!gtk3? (
>=dev-libs/libunique-1:1
>=x11-libs/gtk+-2.24:2[introspection?]
)
gtk3? (
>=dev-libs/libunique-3:3
>=x11-libs/gtk+-3.0:3[introspection?]
)
introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
packagekit? ( app-admin/packagekit-base )
xmp? ( >=media-libs/exempi-1.99.5:2 )
!!mate-base/mate-file-manager"

RDEPEND="${COMMON_DEPEND}"

DEPEND="${COMMON_DEPEND}
>=dev-lang/perl-5:0=
dev-util/gdbus-codegen:0
dev-util/gtk-doc
dev-util/gtk-doc-am
>=dev-util/intltool-0.40.1:*
sys-devel/gettext:*
virtual/pkgconfig:*"

PDEPEND="mate? ( >=x11-themes/mate-icon-theme-${MATE_BRANCH} )"

# TODO: Test fails because Caja is not merged yet:
# GLib-GIO-ERROR **: Settings schema 'org.mate.caja.preferences' is not installed
RESTRICT="test"

src_prepare() {
# Remove unnecessary CFLAGS.
sed -i -e 's:-DG.*DISABLE_DEPRECATED::g' \
configure.ac eel/Makefile.am || die

mate_src_prepare
}

src_configure() {
mate_src_configure \
--disable-update-mimedb \
--with-gtk=$(usex gtk3 3.0 2.0) \
$(use_enable introspection) \
$(use_enable packagekit) \
$(use_enable xmp)
}

src_test() {
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS

Xemake check || die "Test phase failed"
}

pkg_postinst() {
mate_pkg_postinst

elog "Caja can use gstreamer to preview audio files. Just make sure"
elog "to have the necessary plugins available to play the media type you"
elog "want to preview."
}

0 comments on commit 0949042

Please sign in to comment.