Skip to content

Commit

Permalink
dev-qt/qtchooser: new snapshot
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
Pesa committed Oct 26, 2015
1 parent fe119c3 commit 09960cc
Show file tree
Hide file tree
Showing 12 changed files with 121 additions and 5 deletions.
1 change: 1 addition & 0 deletions dev-qt/qtchooser/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST qtchooser-0_p20150102.tar.xz 30936 SHA256 7b6d622d3a57a1467c57b4ca368220540085698cb7ad226ed782931599e85757 SHA512 15e08f1aaa22ba45d41adda57b9da76f3667d15ab92448b6a95b44287e5043fcae368ddcea1e2b84565d3a96edacbcd68bc515054ffaa81dde4064c9a992dbae WHIRLPOOL 4617444cf9764a82f10f3ff8fdf1102d9c5fdd76c77966c661a5256a98221117696ffccf83ed5b961a53d7b5ff5e0a7f6454627a6ab43427583edf9e3660a1bb
DIST qtchooser-0_p20151008.tar.xz 31308 SHA256 121e90dd70054701c52b0d555ffa2a55192439afded88197f17d7b2ca28fa2e8 SHA512 d6fd56e839b7ce7abbd42300d76d06d67fabb5ca36a6f6a39493b7770599372c4795a90cafeea8cceff8da7ea7f6639d74f76a8241a808364a41905fa3d084c6 WHIRLPOOL 8e5fc7d1b30d06990af87737e7d5a4b210f0f30ef2d8d7a17b7ef91e02afdb9bce7240c7f291d557855a277c4d5c4c3f452c416ea29a9f1f9a23c9aeface4ae3
75 changes: 75 additions & 0 deletions dev-qt/qtchooser/qtchooser-0_p20151008.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit qmake-utils toolchain-funcs

DESCRIPTION="Qt4/Qt5 version chooser"
HOMEPAGE="https://qt.gitorious.org/qt/qtchooser"
SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${P}.tar.xz"

LICENSE="|| ( LGPL-2.1 GPL-3 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="test"

DEPEND="test? (
dev-qt/qtcore:5
dev-qt/qttest:5
)"
RDEPEND="
!<dev-qt/assistant-4.8.6:4
!<dev-qt/designer-4.8.6:4
!<dev-qt/linguist-4.8.6:4
!<dev-qt/pixeltool-4.8.6:4
!<dev-qt/qdbusviewer-4.8.6:4
!<dev-qt/qt3support-4.8.6:4
!<dev-qt/qtbearer-4.8.6:4
!<dev-qt/qtcore-4.8.6:4
!<dev-qt/qtdbus-4.8.6:4
!<dev-qt/qtdeclarative-4.8.6:4
!<dev-qt/qtdemo-4.8.6:4
!<dev-qt/qtgui-4.8.6:4
!<dev-qt/qthelp-4.8.6:4
!<dev-qt/qtmultimedia-4.8.6:4
!<dev-qt/qtopengl-4.8.6:4
!<dev-qt/qtopenvg-4.8.6:4
!<dev-qt/qtphonon-4.8.6:4
!<dev-qt/qtscript-4.8.6:4
!<dev-qt/qtsql-4.8.6:4
!<dev-qt/qtsvg-4.8.6:4
!<dev-qt/qttest-4.8.6:4
!<dev-qt/qtwebkit-4.8.6:4
!<dev-qt/qtxmlpatterns-4.8.6:4
"

qtchooser_make() {
emake \
CXX="$(tc-getCXX)" \
LFLAGS="${LDFLAGS}" \
prefix="${EPREFIX}/usr" \
"$@"
}

src_compile() {
qtchooser_make
}

src_test() {
pushd tests/auto >/dev/null || die
eqmake5
popd >/dev/null || die

qtchooser_make check
}

src_install() {
qtchooser_make INSTALL_ROOT="${D}" install

keepdir /etc/xdg/qtchooser

# TODO: bash and zsh completion
# newbashcomp scripts/${PN}.bash ${PN}
}
4 changes: 4 additions & 0 deletions profiles/arch/alpha/package.use.mask
Original file line number Diff line number Diff line change
Expand Up @@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Davide Pesavento <[email protected]> (26 Oct 2015)
# Tests require non-keyworded qt5
dev-qt/qtchooser test

# Justin Lecher <[email protected]> (14 Oct 2015)
# Requires dev-python/ipython which triggers a long dep chain
dev-python/restkit cli
Expand Down
6 changes: 5 additions & 1 deletion profiles/arch/amd64-fbsd/package.use.mask
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Davide Pesavento <[email protected]> (26 Oct 2015)
# Tests require non-keyworded qt5
dev-qt/qtchooser test

# Johannes Huber <[email protected]> (28 Jan 2015)
# Missing keyword on dev-libs/botan,dev-libs/pkcs11-helper
# Missing keyword on dev-libs/botan and dev-libs/pkcs11-helper
app-crypt/qca botan pkcs11

# Michael Palimaka <[email protected]) (26 Dec 2014)
Expand Down
4 changes: 4 additions & 0 deletions profiles/arch/ia64/package.use.mask
Original file line number Diff line number Diff line change
Expand Up @@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Davide Pesavento <[email protected]> (26 Oct 2015)
# Tests require non-keyworded qt5
dev-qt/qtchooser test

# Justin Lecher <[email protected]> (14 Oct 2015)
# Requires dev-python/ipython which triggers a long dep chain
dev-python/restkit cli
Expand Down
4 changes: 4 additions & 0 deletions profiles/arch/mips/package.use.mask
Original file line number Diff line number Diff line change
Expand Up @@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Davide Pesavento <[email protected]> (26 Oct 2015)
# Tests require non-keyworded qt5
dev-qt/qtchooser test

# Mike Frysinger <[email protected]> (10 Sep 2015)
# Requires matplotlib which requires a bit more.
dev-python/numpydoc test
Expand Down
4 changes: 4 additions & 0 deletions profiles/arch/powerpc/ppc32/package.use.mask
Original file line number Diff line number Diff line change
Expand Up @@ -4,6 +4,10 @@

# This file requires >=portage-2.1.1

# Davide Pesavento <[email protected]> (26 Oct 2015)
# Tests require non-keyworded qt5
dev-qt/qtchooser test

# Ben de Groot <[email protected]> (20 Jul 2015)
# missing keyword
media-sound/audacity midi
Expand Down
4 changes: 4 additions & 0 deletions profiles/arch/sparc/package.use.mask
Original file line number Diff line number Diff line change
Expand Up @@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Davide Pesavento <[email protected]> (26 Oct 2015)
# Tests require non-keyworded qt5
dev-qt/qtchooser test

# Sergey Popov <[email protected]> (24 Oct 2015)
# Not tested
net-mail/dovecot lz4
Expand Down
4 changes: 4 additions & 0 deletions profiles/arch/x86-fbsd/package.use.mask
Original file line number Diff line number Diff line change
Expand Up @@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Davide Pesavento <[email protected]> (26 Oct 2015)
# Tests require non-keyworded qt5
dev-qt/qtchooser test

# Johannes Huber <[email protected]> (28 Jan 2015)
# Missing keyword on dev-libs/botan
app-crypt/qca botan
Expand Down
8 changes: 6 additions & 2 deletions profiles/default/linux/uclibc/mips/package.use.mask
Original file line number Diff line number Diff line change
@@ -1,9 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Davide Pesavento <[email protected]> (26 Oct 2015)
# Tests require non-keyworded qt5
dev-qt/qtchooser test

# Anthony G. Basile <[email protected]> (10 Sep 2015)
# # seccomp code is currently broken, bug #560098
# seccomp code is currently broken, bug #560098
app-misc/pax-utils seccomp

# Matthias Maier <[email protected]> (24 Dec 2014)
Expand Down
6 changes: 5 additions & 1 deletion profiles/default/linux/uclibc/ppc/package.use.mask
Original file line number Diff line number Diff line change
@@ -1,6 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation.
# Copyright 1999-2015 Gentoo Foundation.
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Davide Pesavento <[email protected]> (26 Oct 2015)
# Tests require non-keyworded qt5
dev-qt/qtchooser test

dev-libs/libpcre cxx
sys-libs/ncurses cxx
Original file line number Diff line number Diff line change
@@ -1,7 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Davide Pesavento <[email protected]> (26 Oct 2015)
# Tests require non-keyworded qt5
dev-qt/qtchooser test

# Kacper Kowalik <[email protected]> (25 Apr 2012)
# Masking due to unsolved dependencies
app-admin/puppet rrdtool

0 comments on commit 09960cc

Please sign in to comment.