Skip to content

Commit

Permalink
dev-util/coccinelle: bump to 1.0.5.
Browse files Browse the repository at this point in the history
Cleanup a bit ebuild.
Remove backward compat dep for camlp4.

Package-Manager: portage-2.3.0_rc1
  • Loading branch information
aballier committed Jun 23, 2016
1 parent 5885b80 commit 09f5b99
Show file tree
Hide file tree
Showing 2 changed files with 124 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/coccinelle/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST coccinelle-1.0.0.tgz 3427246 SHA256 e18b4c77964c6f623c385dc8b2fcb46beacd981
DIST coccinelle-1.0.1.tgz 2772730 SHA256 39caac46c1f80cbe5de21164c5b31a794e3befdb9cd7ef1d080d455ac171b526 SHA512 5a69476941a9582ca6e0663c468a87aba15b6e38243cbb532c517b75066c8fafe37cbe6d398d6183cc7a315c5680efdf425f0bc8cb2184dbf94e446879514a89 WHIRLPOOL 8b38b982b8d19c10c7e3ed77629b6883c4d6455da4da4d68251b492ce36490c5236573bf7c44a34e21887b8be0ca83b4efb39cf13b1c4c6db7db58979ee6a7bc
DIST coccinelle-1.0.2.tgz 2790829 SHA256 4e45b904f42c9b84732168782d491c8c1ab23bb85db06c4b9ba2762bea8ac679 SHA512 83c8e250a7e19126ce3f95d0455892d60b2d7a688af3a066edcfb9a8cc146f8a9281c9e019896421e1bc546d366114effef3116105eae19617ad45c26f42c534 WHIRLPOOL 15b64abbad31f49883e4cacc2282ed28eb67f64d951636ee6b690a474b072e6a029c4131adb727f5f7a8d86628b871db0cff144ad8478514529c4c5d5dee9074
DIST coccinelle-1.0.4.tgz 2484218 SHA256 7f823813a2ea299c0f6c01d8419b83c4dc6617116d32ba99d726443a1c22b06d SHA512 1e7ad7adb700f2e0d844b3f5787c24fc40bc9a61354b5aefa0f957e524e74ba67a8bef594e837a479d3a5f3c8d89c2395e8636838e0451977de8bd3d588d7ce1 WHIRLPOOL 15759395a2253fa8322e034a02388b5f0f6cc0702e82d43e95c3c9ecc2fa5795cb4a3a3fbc48aa2104bd0173adfd58e046f804d63c3ccbe278796cbe4932f46e
DIST coccinelle-1.0.5.tgz 5660596 SHA256 5efb093b538145b7526a06946c09c7caaa715006658af2049faa8739f459743b SHA512 0fee450554abc40feac9e745a252c1679f8016c82f04236e642e32e129618a950bb9657f1c447d62543289e95bbd4b1a8b0c6030373025c32a37068f82d30678 WHIRLPOOL 33ec9789d93f6cd35eda37f0647d3e3f3f53898fccc2df68aa30cec50ce82b4d392d84a0c97708cdf301b2f076cce1942b5d4a51dffb0bd177eb9dee460d3e6f
123 changes: 123 additions & 0 deletions dev-util/coccinelle/coccinelle-1.0.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,123 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
PYTHON_COMPAT=( python2_7 )

inherit multilib eutils python-single-r1 bash-completion-r1 elisp-common

MY_P="${P/_/-}"
DESCRIPTION="Program matching and transformation engine"
HOMEPAGE="http://coccinelle.lip6.fr/"
SRC_URI="http://coccinelle.lip6.fr/distrib/${MY_P}.tgz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

# ocaml enables ocaml scripting (uses findlib)
CDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
dev-ml/sexplib:=[ocamlopt?]
dev-ml/menhir:=[ocamlopt?]
dev-ml/camlp4:=[ocamlopt?]
dev-ml/parmap:=[ocamlopt?]
emacs? ( virtual/emacs )
ocaml? ( dev-ml/findlib:= )
pcre? ( dev-ml/pcre-ocaml:=[ocamlopt?] )
python? ( ${PYTHON_DEPS} )"

RDEPEND="${CDEPEND}
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"

# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
DEPEND="${CDEPEND}
virtual/pkgconfig
doc? (
virtual/latex-base
dev-texlive/texlive-latexextra
dev-texlive/texlive-fontsextra
)"

DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )

S=${WORKDIR}/${MY_P}

SITEFILE=50coccinelle-gentoo.el

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
if use python ; then
# fix python install location
sed -e "s:\$(LIBDIR)/python:$(python_get_sitedir):" \
-i Makefile || die
fi
}

src_configure() {
econf \
$(use_enable python) \
$(use_enable ocaml) \
$(use_enable pcre) \
$(use_enable pcre pcre-syntax) \
$(use_enable ocamlopt opt)
}

src_compile() {
emake depend

if use ocamlopt ; then
emake all.opt
else
emake TARGET_SPATCH=byte-only all-dev
fi

if use doc ; then
VARTEXFONTS="${T}"/fonts emake docs
fi

if use emacs ; then
elisp-compile editors/emacs/cocci.el || die
fi
}

src_test() {
emake check
use python && emake pycocci-check
}

src_install() {
default

use doc && dodoc docs/manual/*.pdf
newbashcomp scripts/spatch.bash_completion spatch

if use emacs ; then
elisp-install ${PN} editors/emacs/*
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi

if use vim-syntax ; then
newdoc editors/vim/README README-vim
rm editors/vim/README || die
insinto /usr/share/vim/vimfiles
doins -r editors/vim/*
fi

use python && python_optimize

export STRIP_MASK='*/coccinelle/spatch'
}

pkg_postinst() {
use emacs && elisp-site-regen
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit 09f5b99

Please sign in to comment.