Skip to content

Commit

Permalink
lxqt-base/lxqt-runner: add version 0.15.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <[email protected]>
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
Chiitoo authored and a17r committed May 20, 2020
1 parent 550f80f commit 0a02905
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions lxqt-base/lxqt-runner/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST lxqt-runner-0.14.1.tar.xz 223628 BLAKE2B c9f5879bc4c58d0a9cbc19e6efef7fc26bd479e14b7e7109458501372e9b3e251bf87889a1913e6bbc99b68b96b450e71ca57c764aac52afedd35e9904aedd40 SHA512 62d196d37e87bc9154fa2cd9abcb8671277bffdb8673a6531bcb93161944cb8a31298587f8323d79a290292fc73765ea15990106828335879b87029ff1aba28c
DIST lxqt-runner-0.15.0.tar.xz 223996 BLAKE2B 90e078d4a2cb93bfc9f964cf4cdcee73e4d5a390ec1383f623b96f15646dec7cff630d95dcd3613427063213c951325826c69d5bff6ee8b9b3024133ed01166c SHA512 559a5ef627f311ee4894891445a7f1bf70349d7f89ec3eb1d5550f8e87486d695d03fb70a8ec936b074e83c82c29ff26c07ee3edeebbbf8dade2d9a5f4dacdba
47 changes: 47 additions & 0 deletions lxqt-base/lxqt-runner/lxqt-runner-0.15.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake

DESCRIPTION="LXQt quick launcher"
HOMEPAGE="https://lxqt.github.io/"

MY_PV="$(ver_cut 1-2)*"

if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
fi

LICENSE="LGPL-2.1 LGPL-2.1+"
SLOT="0"

BDEPEND="
dev-qt/linguist-tools:5
>=dev-util/lxqt-build-tools-0.7.0
virtual/pkgconfig
"
DEPEND="
>=dev-cpp/muParser-2.2.3:=
>=dev-libs/libqtxdg-3.3.1
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
kde-frameworks/kwindowsystem:5
=lxqt-base/liblxqt-${MY_PV}
=lxqt-base/lxqt-globalkeys-${MY_PV}
"
RDEPEND="${DEPEND}
!lxqt-base/lxqt-l10n
"

src_install() {
cmake_src_install
doman man/*.1
}

0 comments on commit 0a02905

Please sign in to comment.