Skip to content

Commit

Permalink
net-dns/dnscrypt-proxy: version bump to 1.6.0 and various fixes
Browse files Browse the repository at this point in the history
* remove unused eutils inherit
* fix dependency on sys-apps/systemd (it's not just RDEPEND)
* add missing DEPEND on virtual/pkgconfig
* remove automagic dependency on ldns to avoid dependency
  breakage and depend on it unconditionally (there is no
  build-system switch)
* don't install COPYING, it's already in LICENSE variable,
  also simplify DOCS string
* add pkg_postinst() information on usage
* minor cosmetic changes
  • Loading branch information
Julian Ospald committed Oct 22, 2015
1 parent 0d0b93b commit 0a1505c
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-dns/dnscrypt-proxy/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST dnscrypt-proxy-1.4.2.tar.gz 1592962 SHA256 1d519068c30868bb60a151908f0e300a1754b234f7bc2ad1d749ad9d0d977076 SHA512 ecb81b5d20cf88a610421bb1266861a2f5dd34d0ce916c54507507ca5dbe5d9e49e95916f76fa7997b112860f2bc37793f075ed812c75b2904adf6cdf32cac17 WHIRLPOOL ddfa3da3de933f6cbb8721ccd6435e97b9e893d32311e1c3badbc23b6a0547b6cb0f8d6037baaf0027ca1eb972c4be167dc9ce56194f7f6fa54fac974ca0bd24
DIST dnscrypt-proxy-1.4.3.tar.gz 1560345 SHA256 f10f10c18e25ced3c5ec5d0c4145d33270f9cfa991fd1b18d5d9af00e4d9b68e SHA512 3aae9f20bc06087b0860a24488bcda117010a34218d7aef3c68a0f155f8164ce06a88865a9caf1ce5c5eaa8588518ccc2c8a61a97cc39f527f7b2b14cdf8c118 WHIRLPOOL 49915b0f95d340828c79febc9b7d94c4f0c444e016b9f78d134e05f43945b446ab71bbc6a230d6e15d5f1f4c0b97d9f671b6001314cc157cdcd419b01bf23550
DIST dnscrypt-proxy-1.6.0.tar.gz 1579293 SHA256 7703a41a1040fc30b19fdfbbaba36b411e66d998584b0e2fa5088f734f4f86be SHA512 1937a80ab0e6e5786b0d004fef1c007d9d8a4df335542ae6f96c1eac7739920f2ff4b469d30abac774c12a41d275c2a8bf31b5514d7af446028cedeeb3efcf02 WHIRLPOOL b24eb58bca1ff8fa55fec3836399a3ee5c66823d8b459e5f8ce7aa653454407dc3b80d7dc050b76e5c0595fc0e2d854478a6f949ef859b149f6b20e127c98274
58 changes: 58 additions & 0 deletions net-dns/dnscrypt-proxy/dnscrypt-proxy-1.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit systemd user

DESCRIPTION="A tool for securing communications between a client and a DNS resolver"
HOMEPAGE="http://dnscrypt.org/"
SRC_URI="http://download.dnscrypt.org/${PN}/${P}.tar.gz"

LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+plugins systemd"

CDEPEND="
dev-libs/libsodium
net-libs/ldns
systemd? ( sys-apps/systemd )"
RDEPEND="${CDEPEND}"
DEPEND="${CDEPEND}
virtual/pkgconfig"

DOCS="AUTHORS ChangeLog NEWS README* TECHNOTES THANKS"

pkg_setup() {
enewgroup dnscrypt
enewuser dnscrypt -1 -1 /var/empty dnscrypt
}

src_configure() {
econf \
$(use_enable plugins) \
$(use_with systemd)
}

src_install() {
default

newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
systemd_dounit "${FILESDIR}"/${PN}.service
}

pkg_postinst() {
elog "After starting the service you will need to update your"
elog "/etc/resolv.conf and replace your current set of resolvers"
elog "with:"
elog
elog "nameserver <DNSCRYPT_LOCALIP>"
elog
elog "where <DNSCRYPT_LOCALIP> is what you supplied in"
elog "/etc/conf.d/dnscrypt-proxy, default is \"127.0.0.1\"."
elog
elog "Also see https://github.com/jedisct1/dnscrypt-proxy#usage."
}

0 comments on commit 0a1505c

Please sign in to comment.