forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/libyami: bump to 1.3.0; add := dep on libva
Package-Manager: Portage-2.3.19, Repoman-2.3.6
- Loading branch information
Showing
3 changed files
with
98 additions
and
3 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST libyami-1.0.1.tar.gz 480656 BLAKE2B 245c26dcfd396000eaf60d25bf437aad8dcd5255aac2b23ab0299bbf707e52268a914df61e2194dfb67a76d52eb1a8b792c07e777b77975d19ff11a2aa616397 SHA512 01c0716011682ff8b5e6d2c58479aa574bc2cfb5ffe932952e430302aff090d56e0efa4f784f9cdd36d94800c8454802e4500096b3bea162d04ee6253a134c81 | ||
DIST libyami-1.1.0.tar.gz 491537 BLAKE2B fc3b948954ceda10894ff29f5f540a5817a962e2da6d549f0d0b4d89602577437778a244bcaff5fee4f3760d98472d8cd1c0ac07146e3b6ad34618c9f937eeec SHA512 04ef34a994d23f8f5182c17975d6a28048a311c8090393d8cd54dd1fc74ec8b76af4028e1d5506568fb698e15f14833a01d4eaeb4ccd2484801f806a05cc86fa | ||
DIST libyami-1.2.0.tar.gz 508386 BLAKE2B ed4892dddd66d03a5f37c4d28a449c18c722bd1a09aae6261d3b3a210fc4912f728f629a216efd7176c8a37de768a6fa2d1272ca223a387e5cfb8cb4e7cb284d SHA512 1d253d67e3aab7ff2a1add50f7a5ebd284518d12fa689e6160a2dadb3fd1c2a5ab1a1c5f66dfd3801d46d9666c73dabcd5302ca495b069f60671337c0d0bc539 | ||
DIST libyami-1.3.0.tar.gz 820807 BLAKE2B 3764e591269f3c38e7b5f6f5c3dbfb59fe4cdb198cd80858a2c0150274be073c1b064b8c8482b87ba770a6ee3534430b00155b34fa70f6bab7ed537a85ba1ed1 SHA512 8858c7f8d0fa7ce4547f762484e4b82477e49a8cb893cde29d7a26ba0f39dfcabc530659722ee5b84dc6f95e65c3373057ef470c78b9c1d790907e7bd6c6fd75 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,93 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
|
||
SCM="" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
SCM=git-r3 | ||
EGIT_REPO_URI="https://github.com/01org/libyami" | ||
fi | ||
|
||
inherit ${SCM} autotools multilib-minimal flag-o-matic | ||
|
||
DESCRIPTION="Yet Another Media Infrastructure: Media codec with hardware acceleration" | ||
HOMEPAGE="https://github.com/01org/libyami" | ||
|
||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
KEYWORDS="" | ||
SRC_URI="" | ||
else | ||
KEYWORDS="~amd64" | ||
SRC_URI="https://github.com/01org/libyami/archive/${P}.tar.gz" | ||
S="${WORKDIR}/${PN}-${P}" | ||
fi | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="debug egl dmabuf doc md5 v4l X test wayland" | ||
|
||
RDEPEND=" | ||
>=x11-libs/libva-1.7.2:=[drm,X?,wayland?,${MULTILIB_USEDEP}] | ||
v4l? ( | ||
>=virtual/opengl-7[${MULTILIB_USEDEP}] | ||
>=media-libs/libv4l-1.6.2[${MULTILIB_USEDEP}] | ||
>=media-libs/mesa-10[egl,gles2,${MULTILIB_USEDEP}] | ||
) | ||
X? ( >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] ) | ||
md5? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] ) | ||
dmabuf? ( x11-libs/libdrm[${MULTILIB_USEDEP}] ) | ||
" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig | ||
doc? ( app-doc/doxygen ) | ||
test? ( >=dev-cpp/gtest-1.7 ) | ||
" | ||
|
||
src_prepare() { | ||
sed -i -e 's/-Werror//' configure.ac || die | ||
eautoreconf | ||
} | ||
|
||
multilib_src_configure() { | ||
append-cppflags -I"${S}/" -I"${BUILD_DIR}/interface" | ||
append-cxxflags -fpermissive | ||
ECONF_SOURCE="${S}" econf \ | ||
$(use_enable debug) \ | ||
$(use_enable egl) \ | ||
$(use_enable v4l v4l2) \ | ||
$(use_enable v4l v4l2-ops) \ | ||
$(use_enable X x11) \ | ||
$(use_enable dmabuf) \ | ||
$(use_enable md5) \ | ||
$(use_enable wayland) \ | ||
$(use_enable test gtest) \ | ||
$(multilib_native_use_enable doc docs) \ | ||
--enable-h265dec \ | ||
--enable-vc1dec \ | ||
--enable-h264dec \ | ||
--enable-jpegdec \ | ||
--enable-mpeg2dec \ | ||
--enable-vp8dec \ | ||
--enable-vp9dec \ | ||
--enable-h265enc \ | ||
--enable-h264enc \ | ||
--enable-jpegenc \ | ||
--enable-vp8enc \ | ||
--enable-vp9enc | ||
} | ||
|
||
multilib_src_compile() { | ||
emake | ||
multilib_is_native_abi && use doc && emake -C doc | ||
} | ||
|
||
multilib_src_install() { | ||
emake DESTDIR="${D}" install | ||
multilib_is_native_abi && use doc && dohtml -r doc/html/* | ||
} | ||
|
||
src_install() { | ||
multilib-minimal_src_install | ||
find "${ED}" -name '*.la' -delete | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters