Skip to content

Commit

Permalink
app-emulation/docker-compose: 1.27.3
Browse files Browse the repository at this point in the history
Signed-off-by: Sebastian Pipping <[email protected]>
Package-Manager: Portage-3.0.0, Repoman-2.3.23
  • Loading branch information
hartwork committed Sep 18, 2020
1 parent bb87218 commit 0b01a98
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/docker-compose/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,3 +7,4 @@ DIST docker-compose-1.27.0_rc1.tar.gz 308050 BLAKE2B 347dc4b38feae1d045770ff981a
DIST docker-compose-1.27.0_rc2.tar.gz 308129 BLAKE2B f057d9754040375f71810bbf09cd6a88c9ff05665b4629e0cf45c457b10ff9c4bde1b7a608addb160bcc183d8559a8cb2397f7a2215c1b14ae39577bdb67826b SHA512 556a3b10144ff37996c6e3cd1562ba3fdde2618757d305ead4f861c6614f27bad0cf539885535ca61abaf9e9739bbb1c2b41c489ba87ad75f947213d4cdace19
DIST docker-compose-1.27.0_rc3.tar.gz 308370 BLAKE2B 094a28a4de8f32dfd82e0720a68cdae1493f63dc553e663081df3b9edf89593c76fba6b67eddcd1d1cd22966345e7d9a535e8603ed3a8f619fda41a1a8b1db9f SHA512 ad996f0df612741ce36e3549d846d3fc507f687e41ed4fb5bd694faa48906da7ca4054d56ab90fe2e64d4548955ec366867be29a449044c357e45b147e475fd9
DIST docker-compose-1.27.2.tar.gz 309004 BLAKE2B 1017016989b25afa812d2e7251c6dbf45922867d66ef0c69292889a5de8f31908c8d2f418b2c29c319fbd7d0ba4e213d932665e7128b61164295105f35b23579 SHA512 2156a2b283d0ace6a8bfb0d6bbe93bfca7cd651c30fdeea4e1fa2acc6a85790d34a869d4625ef83ad11e9ecc1fbc1e9acac6f40eb8ef5225ccc36bab2ddcf847
DIST docker-compose-1.27.3.tar.gz 309220 BLAKE2B eaf066f24bfff893e515a460be9abba79a59e5112a3a34a9002870babefd93950cf92ef66db469102c37e781d7fb986de069eef3fa09e4041b3a43d8bf1a3d30 SHA512 43e34760574d1ec009faa7a1fa09d621a2708f01f05819b46c67fe7ebf280807f97d9a5867cbfe75e9af6f097cd3f7c8c8fee66aa5392a4c62cdf44c7fb38075
73 changes: 73 additions & 0 deletions app-emulation/docker-compose/docker-compose-1.27.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 2018-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend

inherit bash-completion-r1 distutils-r1

MY_PV=${PV/_/-}
DESCRIPTION="Multi-container orchestration for Docker"
HOMEPAGE="https://github.com/docker/compose"
SRC_URI="https://github.com/docker/compose/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
>=dev-python/distro-1.5.0[${PYTHON_USEDEP}]
>=dev-python/docker-py-4.3.1[${PYTHON_USEDEP}]
>=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
>=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
>=dev-python/python-dotenv-0.13.0[${PYTHON_USEDEP}]
>=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
dev-python/paramiko[${PYTHON_USEDEP}]
>=dev-python/PySocks-1.6.0[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
>=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
>=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
>=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"

DEPEND="${RDEPEND}
test? (
>=dev-python/pytest-5[${PYTHON_USEDEP}]
>=dev-python/ddt-1.2.2[${PYTHON_USEDEP}]
)"

S="${WORKDIR}/compose-${MY_PV}"

PATCHES=(
# Bug #679968 -- https://bugs.gentoo.org/679968
# Bug #681002 -- https://bugs.gentoo.org/681002
"${FILESDIR}"/${PN}-1.27.0_rc3-setup-py.patch
)

DOCS=( CHANGELOG.md README.md )

src_prepare() {
# Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die

default
}

python_test() {
distutils_install_for_testing
${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
}

python_install_all() {
newbashcomp contrib/completion/bash/docker-compose ${PN}

insinto /usr/share/zsh/site-functions
doins contrib/completion/zsh/*

distutils-r1_python_install_all
}

0 comments on commit 0b01a98

Please sign in to comment.