Skip to content

Commit

Permalink
games-board/gnome-hearts: Drop libgnomeui requirement with the ArchLi…
Browse files Browse the repository at this point in the history
…nux patch

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
pacho2 committed Feb 11, 2017
1 parent 64f076a commit 0bdcb91
Show file tree
Hide file tree
Showing 2 changed files with 110 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
diff -Naur gnome-hearts-0.3.1.orig/configure.in gnome-hearts-0.3.1/configure.in
--- gnome-hearts-0.3.1.orig/configure.in 2013-06-09 15:05:11.000000000 +0200
+++ gnome-hearts-0.3.1/configure.in 2017-01-20 23:20:35.677689797 +0100
@@ -23,7 +23,7 @@
fi

# Check for libraries. gmodule is required to make sure --export-dynamic is used and glade works
-PKG_CHECK_MODULES(GNOME_HEARTS, [libgnomeui-2.0 gtk+-2.0 libglade-2.0 glib-2.0 gmodule-2.0])
+PKG_CHECK_MODULES(GNOME_HEARTS, [gtk+-2.0 libglade-2.0 glib-2.0 gmodule-2.0])
AC_SUBST(GNOME_HEARTS_CFLAGS)
AC_SUBST(GNOME_HEARTS_LIBS)

diff -Naur gnome-hearts-0.3.1.orig/src/events.c gnome-hearts-0.3.1/src/events.c
--- gnome-hearts-0.3.1.orig/src/events.c 2013-06-09 15:01:08.000000000 +0200
+++ gnome-hearts-0.3.1/src/events.c 2017-01-20 23:35:17.428651148 +0100
@@ -71,13 +71,13 @@
/* Open the help file */
void on_help(GtkWidget *widget, gpointer data)
{
- gnome_help_display("gnome-hearts.xml", NULL, NULL);
+ gtk_show_uri(NULL, "ghelp:gnome-hearts", GDK_CURRENT_TIME, NULL);
}

/* Open the preferences help file */
void on_preferences_help(GtkWidget *widget, gpointer data)
{
- gnome_help_display("gnome-hearts.xml", "hearts-prefs", NULL);
+ gtk_show_uri(NULL, "ghelp:gnome-hearts?hearts-prefs", GDK_CURRENT_TIME, NULL);
}

/* About menu item */
diff -Naur gnome-hearts-0.3.1.orig/src/hearts.c gnome-hearts-0.3.1/src/hearts.c
--- gnome-hearts-0.3.1.orig/src/hearts.c 2013-06-09 15:01:08.000000000 +0200
+++ gnome-hearts-0.3.1/src/hearts.c 2017-01-20 23:20:21.447210208 +0100
@@ -534,15 +534,11 @@
setlocale(LC_ALL, "");
#endif

- /* Initialize GNOME */
+ /* Initialize GTK+ */
GOptionContext *option_context = g_option_context_new(_("- Play a game of hearts"));
g_option_context_add_main_entries(option_context, option_entries, GETTEXT_PACKAGE);

- gnome_program_init(PACKAGE, VERSION, LIBGNOMEUI_MODULE,
- argc, argv,
- GNOME_PARAM_GOPTION_CONTEXT, option_context,
- GNOME_PARAM_APP_DATADIR, PACKAGE_DATA_DIR,
- GNOME_PARAM_NONE);
+ gtk_init(&argc, &argv);

/* init the game's global variables */
game_score_labels = NULL;
diff -Naur gnome-hearts-0.3.1.orig/src/hearts.h gnome-hearts-0.3.1/src/hearts.h
--- gnome-hearts-0.3.1.orig/src/hearts.h 2013-06-09 15:01:08.000000000 +0200
+++ gnome-hearts-0.3.1/src/hearts.h 2017-01-20 23:22:33.691604109 +0100
@@ -26,7 +26,7 @@
/* headers */
#include <glib/gi18n.h>
#include <dirent.h>
-#include <gnome.h>
+#include <gtk/gtk.h>
#include <glade/glade.h>
#include "cards.h"
#include "cfg.h"
46 changes: 46 additions & 0 deletions games-board/gnome-hearts/gnome-hearts-0.3.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
GNOME2_EAUTORECONF="yes"
PYTHON_COMPAT=( python2_7 )

inherit gnome2 python-single-r1

DESCRIPTION="A clone of classic hearts card game"
HOMEPAGE="http://www.gnome-hearts.org"
SRC_URI="http://www.jejik.com/files/${PN}/${P}.tar.gz"

LICENSE="GPL-2 FDL-1.2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
x11-libs/gtk+:2
>=gnome-base/libglade-2
"
DEPEND="${RDEPEND}
app-text/rarian
dev-util/intltool
virtual/pkgconfig
"

src_prepare() {
# make src_test work
echo gnome-hearts.desktop.in >> po/POTFILES.skip

sed -i \
-e '/No name/d' \
-e '/^Icon/s/.png//' \
-e '/^Encoding/d' \
gnome-hearts.desktop.in || die

eapply "${FILESDIR}"/${P}-drop-libgnomeui.patch

mv configure.in configure.ac || die
gnome2_src_prepare
}

0 comments on commit 0bdcb91

Please sign in to comment.