Skip to content

Commit

Permalink
dev-util/clair: Version bump to 2.0.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.49, Repoman-2.3.10
  • Loading branch information
mrueg committed Sep 6, 2018
1 parent 18d6da5 commit 0c53ff4
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/clair/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST clair-2.0.3.tar.gz 5194681 BLAKE2B b4f809e7699fbf66745c7f528f3f2c249e81541a64c540a8c39b9fa8f5b581d1297abdfe80bdb0ca3aec00010c6c95e8073397df284d2a92a3e95f91049cde80 SHA512 bf2d4ab15efc50bce3e828d0510ceb44463a6c1d978a854b3a05899996203a7c33bb6e60470eccb6e0a1e23b8ff41955cd0fdda4b77a9a7e042e1e27dd2e0885
DIST clair-2.0.4.tar.gz 5194393 BLAKE2B 631ab14acfcf516a5dd65753fe2088dbabf1c7d13a6b079cb09f0c6a3000b346da948d9c6edd16c999753342d67b9bb2165a1b38956ee8957b48953d10490430 SHA512 fee3b9fe2865c0e352b454767383bf47d67bd14f7d08171197350c20f32bc80eb318db10c9fd4bd9da0024dac97ae287cb8dcc7605c3094f4d567122bfe3f7ed
DIST clair-2.0.5.tar.gz 5194565 BLAKE2B 19eb49b5b3d4d3c3694c4aefc21abbdefbc5b6d3a53a0f845c587bfc98052be93bb83283b0b3fe42a5ed950e55390810032abb4ae4eba8de999f99f07528b1a5 SHA512 551b006c32f6e0c93f2ace33151864f876a7e32c85cf13d8e1dcf23b91f79c32d4b4a4c9bbb3991ff6955897c8dcdfdcec2d6fbbbdcf0b684522375269abca89
45 changes: 45 additions & 0 deletions dev-util/clair/clair-2.0.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit user golang-build golang-vcs-snapshot

EGO_PN="github.com/coreos/clair"
EGIT_COMMIT="v${PV}"
ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Vulnerability Static Analysis for Containers"
HOMEPAGE="https://github.com/coreos/clair"
SRC_URI="${ARCHIVE_URI}"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

RDEPEND="app-arch/rpm
app-arch/xz-utils
dev-vcs/git
!!sci-visualization/xd3d" # File collision (Bug #621044)

pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
}

src_compile() {
GOPATH="${S}" go build -o bin/${PN} -v ${EGO_PN}/cmd/${PN} || die
}

src_install() {
dobin bin/${PN}
pushd src/${EGO_PN} || die
dodoc {README,ROADMAP,CONTRIBUTING}.md
insinto /etc/${PN}
doins config.example.yaml
popd || die

newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
keepdir /var/log/${PN}
fowners ${PN}:${PN} /var/log/${PN}
}

0 comments on commit 0c53ff4

Please sign in to comment.