forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-crypt/signing-party: version bump
Closes: https://bugs.gentoo.org/show_bug.cgi?id=646296 Package-Manager: Portage-2.3.19, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
121 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST signing-party_2.6.orig.tar.gz 201210 BLAKE2B 9be19ffafbb42aca36c7fa8a42e9cb2f804cb226f9b0bdcd97d02751b23a6adf055f4667d0e8192c51d96a96978a5807a9ec6bfb21151cedfef1cb32db1d87a0 SHA512 094af9b354d958d382bf99a1f10a9f12585f85769686e3bc9b9b813016f68232775e4002c0a7accbc894c946f7532b32ee7f9b3e23d467b973041c092ba4efb9 | ||
DIST signing-party_2.7.orig.tar.gz 201320 BLAKE2B 4fe5781b610dc8acd5166fc7ce7daa1b856f6617952d5eb226cae0c8c6fcaa196b88ffe313b2d71b8f11423a81e84f2124d9adea86edbfb0d22808473d1c36fe SHA512 d1599ca0cb2dd554b4688bc8c77f4a1dd907d00539bb11abe147300dd2184f8548ebe9fdf793e83e2956a220b1c4bf9e19bd543b77f724b0c8ea4794ac945985 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,120 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
|
||
inherit toolchain-funcs autotools | ||
|
||
DESCRIPTION="A collection of several tools related to OpenPGP" | ||
HOMEPAGE="http://pgp-tools.alioth.debian.org/" | ||
SRC_URI="mirror://debian/pool/main/s/signing-party/${PN}_${PV}.orig.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
dev-lang/perl | ||
app-crypt/libmd | ||
" | ||
RDEPEND="${DEPEND} | ||
>=app-crypt/gnupg-1.3.92 | ||
dev-perl/GnuPG-Interface | ||
dev-perl/Text-Template | ||
dev-perl/MIME-tools | ||
net-mail/qprint | ||
>=dev-perl/MailTools-1.62 | ||
dev-perl/Net-IDN-Encode | ||
virtual/mailx | ||
virtual/mta | ||
|| ( | ||
dev-perl/libintl-perl | ||
dev-perl/Text-Iconv | ||
app-text/recode | ||
)" | ||
S="${WORKDIR}" | ||
|
||
src_prepare() { | ||
default | ||
|
||
# app-crypt/keylookup | ||
rm -r keylookup || die | ||
# media-gfx/springgraph | ||
rm -r springgraph || die | ||
|
||
cd keyanalyze/pgpring || die | ||
sed -i 's/AM_C_PROTOTYPES//' configure.ac || die | ||
eautoreconf | ||
cd "${WORKDIR}" || die | ||
|
||
find . -name Makefile | xargs sed -i -e 's/CFLAGS:=/CFLAGS=/' -e 's/CPPFLAGS:=/CPPFLAGS=/' -e 's/LDFLAGS:=/LDFLAGS=/' | ||
|
||
sed -i "s:/usr/share/doc/signing-party/caff/caffrc.sample:${EPREFIX}/usr/share/doc/${P}/caff/caffrc.sample.gz:g" \ | ||
caff/caff || die | ||
sed -i -e 's/automake[^ ]*/true/g' -e 's/autoconf[^ ]*/true/g' keyanalyze/Makefile || die | ||
sed -i 's/make /\$(MAKE) /' keyanalyze/Makefile || die | ||
} | ||
|
||
src_compile() { | ||
emake \ | ||
CC="$(tc-getCC)" \ | ||
CPPFLAGS="${CPPFLAGS}" \ | ||
CFLAGS="${CFLAGS}" \ | ||
LDFLAGS="${LDFLAGS}" \ | ||
STRIP=true | ||
} | ||
|
||
src_install() { | ||
einstalldocs | ||
|
||
# Check Makefile when a new tool is introduced to this package. | ||
# caff | ||
dobin caff/caff caff/pgp-clean caff/pgp-fixkey | ||
docinto caff | ||
dodoc caff/{README*,THANKS,TODO,caffrc.sample} | ||
# gpgdir | ||
dobin gpgdir/gpgdir | ||
docinto gpgdir | ||
dodoc gpgdir/{VERSION,LICENSE,README,INSTALL,CREDITS,ChangeLog*} | ||
# gpg-key2ps | ||
dobin gpg-key2ps/gpg-key2ps | ||
docinto gpg-key2ps | ||
dodoc gpg-key2ps/README | ||
# gpglist | ||
dobin gpglist/gpglist | ||
# gpg-mailkeys | ||
dobin gpg-mailkeys/gpg-mailkeys | ||
docinto gpg-mailkeys | ||
dodoc gpg-mailkeys/{example.gpg-mailkeysrc,README} | ||
# gpgparticipants | ||
dobin gpgparticipants/gpgparticipants | ||
# gpgwrap | ||
dobin gpgwrap/bin/gpgwrap | ||
docinto gpgwrap | ||
dodoc gpgwrap/{LICENSE,NEWS,README} | ||
doman gpgwrap/doc/gpgwrap.1 | ||
# gpgsigs | ||
dobin gpgsigs/gpgsigs | ||
insinto /usr/share/signing-party | ||
# keyanalyze | ||
# TODO: some of the scripts are intended for webpages, and not really | ||
# packaging, so they are NOT installed yet. | ||
newbin keyanalyze/pgpring/pgpring pgpring-keyanalyze | ||
dobin keyanalyze/{keyanalyze,process_keys} | ||
docinto keyanalyze | ||
dodoc keyanalyze/{README,Changelog} | ||
# See app-crypt/keylookup instead | ||
#dobin keylookup/keylookup | ||
#docinto keylookup | ||
#dodoc keylookup/NEWS | ||
# sig2dot | ||
dobin sig2dot/sig2dot | ||
dodoc sig2dot/README.sig2dot | ||
# See media-gfx/springgraph instead | ||
#dobin springgraph/springgraph | ||
#dodoc springgraph/README.springgraph | ||
# all other manpages, and the root doc | ||
doman */*.1 | ||
dodoc README | ||
} |