Skip to content

Commit

Permalink
dev-libs/libisofs: Version bump. Fix bug #591900.
Browse files Browse the repository at this point in the history
Thanks to Lars Wendler for the report.

Package-Manager: portage-2.2.28
  • Loading branch information
billie80 committed Aug 27, 2016
1 parent 6bfc6a4 commit 0cdfe0c
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libisofs/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libisofs-1.3.8.tar.gz 802154 SHA256 acd7bf42d5d1d5c277f4aad46e5b96229045a38a0fb7d43cfd7841ee3268fda5 SHA512 7e078a4070741d975234ac10ed6cd2a0366724e9fa440e7063c64f91a60c9454c6828e2b7737d6105f36067008495bfcba8327e56892ccb0962027dc78e251ce WHIRLPOOL 660f2cba77e8b83306fe4d40e34f0e94ecc18a8defd0375cadc84c0d964d6c868b2965329e51e3b5139c88e7cb20ee78f817004cb141e8be5528aa00a25d5647
DIST libisofs-1.4.2.tar.gz 820426 SHA256 d5e7f3ea613a78924dde979f699427b1c6b85ba4540d275aa67945b4a70fb3ab SHA512 609a803c091beb1ed8cb177703c5f4480e63d5d115ac20b07a2a906285d6d8f7a311f94ee5f1e6add61d82ca8783405c38a48ae1e142dc97c27e67df99f71dfa WHIRLPOOL 891d4f2f5aef4e59083cc06d8735d47ca92beaae14545c77171e88b4c99747e2321620c9ae61c74c1d8d32999e8376078fc9e22d97c562a6a8b43b923376a151
DIST libisofs-1.4.4.tar.gz 824640 SHA256 2418f0feeea652dc122a39840d58c6931aa1008480385f7403881d82a629bdfd SHA512 1d4e7f8c8cea20d1c4a6e809b3d3240eb227f6a25412199c512aef74e9c5b57f3c0e8e1e899c9782cd3db2ede384587cc19370a7bbfed16ad5c075a7b608bd8c WHIRLPOOL bea0e74107bbaf2d2fdba779dd676d1d4033fb86ad7f5ab3a3093bb54337fb7440e5eacabd812420267d164a0d884083d4c24d744b4224be99b85979fa4813f3
42 changes: 42 additions & 0 deletions dev-libs/libisofs/libisofs-1.4.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils

DESCRIPTION="Open-source library for reading, mastering and writing optical discs"
HOMEPAGE="http://libburnia-project.org/"
SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="acl debug static-libs verbose-debug xattr zlib"

RDEPEND="acl? ( virtual/acl )
xattr? ( sys-apps/attr )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
virtual/pkgconfig"

src_configure() {
econf \
$(use_enable static-libs static) \
$(use_enable debug) \
$(use_enable verbose-debug) \
$(use_enable acl libacl) \
$(use_enable xattr) \
$(use_enable zlib) \
--disable-libjte \
--disable-ldconfig-at-install
}

src_install() {
default

dodoc Roadmap doc/{*.txt,Tutorial}

prune_libtool_files --all
}

0 comments on commit 0cdfe0c

Please sign in to comment.