Skip to content

Commit

Permalink
app-metrics/vault_exporter: bump to EAPI=7
Browse files Browse the repository at this point in the history
Also migrated to GLEP 81 and updated HOMEPAGE.

Closes: https://bugs.gentoo.org/678986
Closes: https://bugs.gentoo.org/701772
Package-Manager: Portage-3.0.16, Repoman-3.0.2
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Mar 7, 2021
1 parent 11ffef7 commit 0ce1364
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 1 deletion.
2 changes: 1 addition & 1 deletion app-metrics/vault_exporter/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,6 @@
<name>William Hubbs</name>
</maintainer>
<upstream>
<remote-id type="github">grapeshot/vault_exporter</remote-id>
<remote-id type="github">Talend/vault_exporter</remote-id>
</upstream>
</pkgmetadata>
43 changes: 43 additions & 0 deletions app-metrics/vault_exporter/vault_exporter-0.1.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

EGO_PN="github.com/grapeshot/vault_exporter"
MY_PV="${PV/_/}"

inherit golang-build golang-vcs-snapshot

DESCRIPTION="Vault exporter for Prometheus"
HOMEPAGE="https://github.com/grapeshot/vault_exporter"
SRC_URI="https://${EGO_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0 BSD MIT MPL-2.0"
SLOT="0"
KEYWORDS="~amd64"

RDEPEND="
acct-group/vault_exporter
acct-user/vault_exporter
"

BDEPEND="${RDEPEND}"

src_compile() {
pushd "src/${EGO_PN}" || die
GOPATH="${S}" emake build
popd || die
}

src_install() {
pushd "src/${EGO_PN}" || die
newbin _output/bin/vault_exporter-v${PV}* vault_exporter
dodoc README.md
popd || die

keepdir /var/log/vault_exporter
fowners vault_exporter:vault_exporter /var/log/vault_exporter

newinitd "${FILESDIR}"/vault_exporter.initd vault_exporter
newconfd "${FILESDIR}"/vault_exporter.confd vault_exporter
}

0 comments on commit 0ce1364

Please sign in to comment.