Skip to content

Commit

Permalink
media-libs/vulkan-layers: Bump to 1.1.106
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Nick Sarnie <[email protected]>
  • Loading branch information
sarnex committed Apr 15, 2019
1 parent 16a48ff commit 0d41903
Show file tree
Hide file tree
Showing 3 changed files with 51 additions and 2 deletions.
1 change: 1 addition & 0 deletions media-libs/vulkan-layers/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST vulkan-layers-1.1.101.tar.gz 1036750 BLAKE2B 5c59ade7826f382cfb5e56e0aa1498686e1035e69b4d51f36ffdfc179b36323850d1004759941dfaa6ae8e6a25cc909d041e840a589d102f82086f339bfaa1c6 SHA512 d962483ab7149d436ac1bafb65d26ae965e147b7bd0dfd610b35cd54598ee84cb961c472d824a33964b117a14f224c984cf73764aef4de787de13b0a1ad29c4a
DIST vulkan-layers-1.1.106.tar.gz 1151285 BLAKE2B 763654d76c0c9d139ab922b2319df8becef5357c140ade3ba5d99cdbf6c7440b156048970202c2735bed4cb7de213d6647e492fa608023c91cf94a4b0353b4b9 SHA512 caf2c54c89aee2760747fc03f6d3e7742687f86aed5f05e1e8beffac35b114fd61af761bf95593f7cbdb3f9dbc92f570916af1225c7cdce3c16ba81024dc2027
DIST vulkan-layers-1.1.82.0.tar.gz 962993 BLAKE2B 6fe541116f8d4d4370cb5a0b2a98c07139577edf20653359f9f149b503c3d2e9aa98e95af14582c80033b535cc4cec5cc5f148396f472aaf75a8767579978a61 SHA512 c34b691a340830462b917890c97dd86c66eac097ba284183d8bf148267b1a881c909b89c6f9ab78ddd03a60cc884c982bc578cc67e4fbaf37d044004b006a65a
DIST vulkan-layers-1.1.92.0.tar.gz 955136 BLAKE2B 8a039c17a231cda732aafd947c01a658c72932048307b81777254236eb6a2945e287cd098c2ee1fa264c21477b30e48ba83bfd0af4fb5f5bcb0adc502cc45a03 SHA512 09b32635bf26cdf3c1f18e57f7c7348a72c25de37c7afe03c0508cf5d3c6f39779d4a819eb92b2bf4f9300d80e757e8aaf9ec2164d7fd9f523f2926a497c08f6
48 changes: 48 additions & 0 deletions media-libs/vulkan-layers/vulkan-layers-1.1.106.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )

if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-ValidationLayers.git"
EGIT_SUBMODULES=()
inherit git-r3
else
EGIT_COMMIT="21638dfbe1f15091659a722a805c9020e87ddf49"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/KhronosGroup/Vulkan-ValidationLayers/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/Vulkan-ValidationLayers-${EGIT_COMMIT}"
fi

inherit python-any-r1 cmake-multilib

DESCRIPTION="Vulkan Validation Layers"
HOMEPAGE="https://github.com/KhronosGroup/Vulkan-ValidationLayers"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="X wayland"

DEPEND="${PYTHON_DEPS}
>=dev-util/glslang-7.11.3113:=[${MULTILIB_USEDEP}]
>=dev-util/spirv-tools-2019.1-r1:=[${MULTILIB_USEDEP}]
>=dev-util/vulkan-headers-1.1.106
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (
x11-libs/libX11:=[${MULTILIB_USEDEP}]
x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
)"

multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=True
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
-DBUILD_WSI_XLIB_SUPPORT=$(usex X)
-DBUILD_TESTS=False
-DGLSLANG_INSTALL_DIR="/usr"
-DCMAKE_INSTALL_INCLUDEDIR="/usr/include/vulkan/"
)
cmake-utils_src_configure
}
4 changes: 2 additions & 2 deletions media-libs/vulkan-layers/vulkan-layers-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -25,9 +25,9 @@ SLOT="0"
IUSE="X wayland"

DEPEND="${PYTHON_DEPS}
>=dev-util/glslang-7.10.2984:=[${MULTILIB_USEDEP}]
>=dev-util/glslang-7.11.3113:=[${MULTILIB_USEDEP}]
>=dev-util/spirv-tools-2019.1-r1:=[${MULTILIB_USEDEP}]
>=dev-util/vulkan-headers-1.1.92.0
>=dev-util/vulkan-headers-1.1.106
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (
x11-libs/libX11:=[${MULTILIB_USEDEP}]
Expand Down

0 comments on commit 0d41903

Please sign in to comment.