Skip to content

Commit

Permalink
games-rpg/drascula: EAPI8 revbump, ebuild improvement
Browse files Browse the repository at this point in the history
games-rpg/drascula was revbumped because of a missing dep on
games-engines/scummvm[vorbis] and also because it requires a newer dat
file to play.

Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Michael Mair-Keimberger <[email protected]>
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
mm1ke authored and ionenwks committed Jul 5, 2021
1 parent 75f6ddc commit 0dc7f81
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-rpg/drascula/Manifest
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
DIST drascula-1.0.zip 32842993 BLAKE2B 5033e8e5f66f74c2b049a1246c62dd33b7b32c3d088575a8d031bc505cd3356c0b364efa9308c99e26e524dc58913cad7cc09424ac6ad30fff38175f952a0151 SHA512 74ca773264e1ed611456b230d6265dade8d745a3adb736f3d6583d43ed6820a25f481ec65612b31d4b3076418f6bc696c82fa0f5085ec43edc91761e95361d11
DIST drascula-2.0.0.dat 219527 BLAKE2B 362cb71aa5c7ec7a391a9e371f7adbfeef7c3d015db562e613ebc5513d0d8661af6880549424c9fff0dde25e8fe3a82bc4658e0bd47eb6b65c071fff0dce9983 SHA512 b57cdde7f686d54b3dd669dc5737e0046c3f38a31c4f78cde1b51dc7dc3a28193a95d5364629716998f958b7c43ed45bdcd0bc32f94ca718e7882d16fea2c015
DIST drascula-2.2.0.dat 259619 BLAKE2B 924dbd42276feef2ef3be599f37316687f1bc4940189082408c5e5eb923d1df2d638a87e4fdf88d443151ec4e4bb4f9c211905c9596b6608691aa40cef1b99b1 SHA512 032731a30561f1c77f2b9f93e80350371afa7673b1140b5a854ceac724c6ed89755af780e9519717f9ac75e7d34a225e03e0d84ebfb5986f6a6cdef0ca018745
DIST drascula-audio-2.0.zip 36531704 BLAKE2B c3426f9c10e1ab5931b6474c1ba5b13a38267db5c8a8b8663e6a9bbea95751d50f4829dc427d962110ec4b0b093f2c5b59a73ca15aedd73c9ceaf1b3b158ec82 SHA512 09018bcfa062e720db6af7b38fa582f1b3674a25e7bb323d894ad767f8bcd449739fc592a10d848f6cac90a8bb51b5148c5c39558f70d29e2a5116b0b196274e
DIST drascula-int-1.1.zip 34855203 BLAKE2B b37f6ed68d3ef6cc70915d68178a0359ae39e9d2a020f84573e8e905ec4fa946ad9328479590d5510f0b03ec5a422a4204ffd3fb6294711ea7b68f0f19899151 SHA512 f8127d09e19dec9abf75b9129792c67f3d36ea80fa69c70eeaa536f7a76f8f29072c21f041a0f9467d595f214392541c09c7a75caca0318e8d1b587db9d099cf
DIST drascula.png 34525 BLAKE2B 1d529b02f08079921ab1021a3012fbef89fd4e9e4933727cdf96c5ce52bc3837d3f636e7b32f33cb92d027cbc330d4fc9280202a6b970821741eb8a44a905346 SHA512 e49fc17cad986b8fa42bd5ede30a1b1ef264182a476168d5c197a31d484555552e824f103b9456898940c68c2f0d751f4c2782a7a95ea92c62e3daec1dd1f52a
68 changes: 68 additions & 0 deletions games-rpg/drascula/drascula-1.0-r4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit desktop wrapper

INT_PV="1.1"
INT_URI="mirror://sourceforge/scummvm/drascula-int-${INT_PV}.zip"
DAT_PV="2.2.0"
AUD_PV="2.0"

DESCRIPTION="Drascula: The Vampire Strikes Back"
HOMEPAGE="http://www.alcachofasoft.com/"
SRC_URI="mirror://sourceforge/scummvm/drascula-${PV}.zip
https://github.com/scummvm/scummvm/raw/v${DAT_PV}/dists/engine-data/drascula.dat -> drascula-${DAT_PV}.dat
sound? ( mirror://sourceforge/scummvm/drascula-audio-${AUD_PV}.zip )
https://salsa.debian.org/games-team/drascula/raw/master/debian/icons/drascula.png
l10n_es? ( ${INT_URI} )
l10n_de? ( ${INT_URI} )
l10n_fr? ( ${INT_URI} )
l10n_it? ( ${INT_URI} )"
S="${WORKDIR}"

LICENSE="drascula"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="l10n_es l10n_de l10n_fr l10n_it +sound"
RESTRICT="mirror"

RDEPEND="games-engines/scummvm[vorbis]"
BDEPEND="app-arch/unzip"

src_unpack() {
if use l10n_es || use l10n_de || use l10n_fr || use l10n_it; then
unpack drascula-int-${INT_PV}.zip
fi
if use sound; then
unpack drascula-audio-${AUD_PV}.zip
fi
unpack drascula-${PV}.zip
}

src_install() {
insinto /usr/share/${PN}
newins "${DISTDIR}"/drascula-${DAT_PV}.dat drascula.dat
doins Packet.001

if use l10n_es || use l10n_de || use l10n_fr || use l10n_it; then
doins ${PN}-int-${INT_PV}/PACKET.00[2-5]

local lang
for lang in es de fr it; do
if use l10n_${lang}; then
make_wrapper ${PN}-${lang} "scummvm -q ${lang} -f -p \"${EPREFIX}/usr/share/${PN}\" drascula"
make_desktop_entry ${PN}-${lang} "Drascula (${lang})"
fi
done
fi

doicon "${DISTDIR}"/${PN}.png
make_wrapper ${PN} "scummvm -f -p \"${EPREFIX}/usr/share/${PN}\" drascula"
make_desktop_entry ${PN} Drascula

use sound && doins -r audio/.

dodoc readme.txt drascula.doc
}

0 comments on commit 0dc7f81

Please sign in to comment.