Skip to content

Commit

Permalink
app-doc/eclass-manpages: Switch the live ebuild to use git
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/571284
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Mar 14, 2019
1 parent 0e56e35 commit 0dded1c
Showing 1 changed file with 10 additions and 25 deletions.
35 changes: 10 additions & 25 deletions app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
Original file line number Diff line number Diff line change
@@ -1,43 +1,28 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
EAPI="7"

inherit git-r3

DESCRIPTION="Collection of Gentoo eclass manpages"
HOMEPAGE="https://www.gentoo.org/"
SRC_URI=""
EGIT_REPO_URI="https://anongit.gentoo.org/git/repo/gentoo.git
https://github.com/gentoo/gentoo.git"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE=""

DEPEND="
|| (
sys-apps/portage
sys-apps/portage-mgorny
)"

S=${WORKDIR}

genit() {
local e=${1:-${ECLASSDIR}}
einfo "Generating man pages from: ${e}"
# Need `bash` because the .sh isn't +x on the servers #451352
env ECLASSDIR=${e} bash "${FILESDIR}"/eclass-to-manpage.sh || die
src_unpack() {
git-r3_fetch
git-r3_checkout '' '' '' eclass
}

src_compile() {
# First process any eclasses found in overlays. Then process
# the main eclassdir last so that its output will clobber anything
# that might have come from overlays. Main tree wins!
local o e
for o in $(portageq get_repos /) ; do
e="$(portageq get_repo_path / ${o})/eclass"
[[ -d ${e} ]] || continue
genit "${e}" || die
done
genit || die
env ECLASSDIR="${S}/eclass" bash "${FILESDIR}"/eclass-to-manpage.sh || die
}

src_install() {
Expand Down

0 comments on commit 0dded1c

Please sign in to comment.