Skip to content

Commit

Permalink
app-forensics/chkrootkit: Version bump to 0.52
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/617428
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
mrueg committed Jan 24, 2018
1 parent 088f4bd commit 0e1c05e
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-forensics/chkrootkit/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST chkrootkit-0.51-gentoo.diff.xz 4708 BLAKE2B 0dacba47222319d9e5bb5d39e0eb4b7074fb3025be885c5fd9564c10f592e04ba4afe2d0c792a2e54fe4c9b1103e366f65af949e7c0db730bf61981fe8fe2364 SHA512 13dca9c272d85d35d736e14896058612f62e1781aac034f06882fe63d956f074a3c67bf308c104f0080323bb127ba01373967b2c28481741d17d83310fe52dd0
DIST chkrootkit-0.51.tar 174080 BLAKE2B 36acd12801d2ac599b71d0c59165c1489309df0365442aa575bb4c505bbfea5d0daad837fa9b7b40c2aa3841fceda199f37fe5832f0685ad3a0a82ff5e653a3b SHA512 adef6823d069b32305605d0eaa3d3701c6a87900646d9509cebe0fd8a2fec0523595d0dcb4576b32245e7638388d3b43858dbc42be68de9971ac8461fcfdeb34
DIST chkrootkit-0.52.tar 40031 BLAKE2B 8bd3518edc11a22dbc7e866de622454f55baa9fcd06a4034489596c0a24d867fec16d134dbc0aaf8b936640177d7dee8e061e39813a3ed261ae657d70f54a47d SHA512 45d66227c185c60166c9ea2a1f89f4594fa7c943c280fd6da5b59b5b355d5fe0d36806ef133fb29f9b2cac0bc05e9c10773ed4fae923a7115cc900818a596d42
57 changes: 57 additions & 0 deletions app-forensics/chkrootkit/chkrootkit-0.52.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils toolchain-funcs

DESCRIPTION="Tool to locally check for signs of a rootkit"
HOMEPAGE="http://www.chkrootkit.org/"
# Upstream named their *uncompressed* tarball .tar.gz (*sigh*)
SRC_URI="ftp://ftp.pangeia.com.br/pub/seg/pac/${P}.tar.gz -> ${P}.tar
https://dev.gentoo.org/~polynomial-c/${PN}-0.51-gentoo.diff.xz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="+cron"

RDEPEND="cron? ( virtual/cron )"

PATCHES=(
"${WORKDIR}"/${PN}-0.51-gentoo.diff
)

src_prepare() {
default
sed -e 's:/var/adm/:/var/log/:g' \
-i chklastlog.c || die
}

src_compile() {
emake CC="$(tc-getCC)" STRIP=true sense
}

src_install() {
dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc strings-static
dodoc ACKNOWLEDGMENTS README*

if use cron ; then
exeinto /etc/cron.weekly
newexe "${FILESDIR}"/${PN}.cron ${PN}
fi
}

pkg_postinst() {
if use cron ; then
elog
elog "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
elog
fi

elog
elog "Some applications, such as portsentry, will cause chkrootkit"
elog "to produce false positives. Read the chkrootkit FAQ at"
elog "http://www.chkrootkit.org/ for more information."
elog
}

0 comments on commit 0e1c05e

Please sign in to comment.