Skip to content

Commit

Permalink
games-mud/kildclient: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Aug 5, 2016
1 parent a7119ee commit 0ff49b3
Showing 1 changed file with 48 additions and 0 deletions.
48 changes: 48 additions & 0 deletions games-mud/kildclient/kildclient-3.0.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit autotools eutils

DESCRIPTION="Powerful MUD client with a built-in PERL interpreter"
HOMEPAGE="http://kildclient.sourceforge.net"
SRC_URI="mirror://sourceforge/kildclient/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc gnutls spell"

RDEPEND="
dev-lang/perl
dev-perl/Locale-gettext
dev-perl/JSON
sys-libs/zlib
x11-libs/gtk+:3
virtual/libintl
spell? ( app-text/gtkspell:3 )
gnutls? ( net-libs/gnutls )"
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig"

PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
)

src_prepare() {
default

eautoreconf
}

src_configure() {
econf \
--localedir=/usr/share/locale \
--docdir=/usr/share/doc/${PF} \
--htmldir=/usr/share/doc/${PF}/html \
$(use_with spell gtkspell) \
$(use_with gnutls libgnutls) \
$(use_with doc docs)
}

0 comments on commit 0ff49b3

Please sign in to comment.