forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-arch/brotli: fix pkg-config linker configuration
Closes: https://bugs.gentoo.org/739832 Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Craig Andrews <[email protected]>
- Loading branch information
Showing
2 changed files
with
130 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,83 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python3_{6,7,8,9} ) | ||
DISTUTILS_OPTIONAL="1" | ||
DISTUTILS_IN_SOURCE_BUILD="1" | ||
|
||
inherit cmake-multilib distutils-r1 | ||
|
||
DESCRIPTION="Generic-purpose lossless compression algorithm" | ||
HOMEPAGE="https://github.com/google/brotli" | ||
|
||
SLOT="0/$(ver_cut 1)" | ||
|
||
RDEPEND="python? ( ${PYTHON_DEPS} )" | ||
DEPEND="${RDEPEND}" | ||
|
||
IUSE="python test" | ||
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )" | ||
|
||
LICENSE="MIT python? ( Apache-2.0 )" | ||
|
||
DOCS=( README.md CONTRIBUTING.md ) | ||
|
||
if [[ ${PV} == "9999" ]] ; then | ||
SRC_URI="" | ||
EGIT_REPO_URI="https://github.com/google/${PN}.git" | ||
inherit git-r3 | ||
else | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris" | ||
SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
fi | ||
|
||
RESTRICT="!test? ( test )" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PV}-linker.patch" | ||
) | ||
|
||
src_prepare() { | ||
use python && distutils-r1_src_prepare | ||
cmake-utils_src_prepare | ||
} | ||
|
||
multilib_src_configure() { | ||
local mycmakeargs=( | ||
-DBUILD_TESTING="$(usex test)" | ||
) | ||
cmake-utils_src_configure | ||
} | ||
src_configure() { | ||
cmake-multilib_src_configure | ||
use python && distutils-r1_src_configure | ||
} | ||
|
||
multilib_src_compile() { | ||
cmake-utils_src_compile | ||
} | ||
src_compile() { | ||
cmake-multilib_src_compile | ||
use python && distutils-r1_src_compile | ||
} | ||
|
||
python_test() { | ||
esetup.py test || die | ||
} | ||
|
||
multilib_src_test() { | ||
cmake-utils_src_test | ||
} | ||
src_test() { | ||
cmake-multilib_src_test | ||
use python && distutils-r1_src_test | ||
} | ||
|
||
multilib_src_install() { | ||
cmake-utils_src_install | ||
} | ||
multilib_src_install_all() { | ||
use python && distutils-r1_src_install | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
From 092446fafb4bfb81738853b7c7f76b293cd92a80 Mon Sep 17 00:00:00 2001 | ||
From: Evgenii Kliuchnikov <[email protected]> | ||
Date: Wed, 2 Sep 2020 10:49:49 +0200 | ||
Subject: [PATCH] Revert "Add runtime linker path to pkg-config files (#740)" | ||
|
||
This reverts commit 31754d4ffce14153b5c2addf7a11019ec23f51c1. | ||
--- | ||
scripts/libbrotlicommon.pc.in | 2 +- | ||
scripts/libbrotlidec.pc.in | 2 +- | ||
scripts/libbrotlienc.pc.in | 2 +- | ||
3 files changed, 3 insertions(+), 3 deletions(-) | ||
|
||
diff --git a/scripts/libbrotlicommon.pc.in b/scripts/libbrotlicommon.pc.in | ||
index 10ca969e..2a8cf7a3 100644 | ||
--- a/scripts/libbrotlicommon.pc.in | ||
+++ b/scripts/libbrotlicommon.pc.in | ||
@@ -7,5 +7,5 @@ Name: libbrotlicommon | ||
URL: https://github.com/google/brotli | ||
Description: Brotli common dictionary library | ||
Version: @PACKAGE_VERSION@ | ||
-Libs: -L${libdir} -R${libdir} -lbrotlicommon | ||
+Libs: -L${libdir} -lbrotlicommon | ||
Cflags: -I${includedir} | ||
diff --git a/scripts/libbrotlidec.pc.in b/scripts/libbrotlidec.pc.in | ||
index e7c3124f..6f8ef2e4 100644 | ||
--- a/scripts/libbrotlidec.pc.in | ||
+++ b/scripts/libbrotlidec.pc.in | ||
@@ -7,6 +7,6 @@ Name: libbrotlidec | ||
URL: https://github.com/google/brotli | ||
Description: Brotli decoder library | ||
Version: @PACKAGE_VERSION@ | ||
-Libs: -L${libdir} -R${libdir} -lbrotlidec | ||
+Libs: -L${libdir} -lbrotlidec | ||
Requires.private: libbrotlicommon >= 1.0.2 | ||
Cflags: -I${includedir} | ||
diff --git a/scripts/libbrotlienc.pc.in b/scripts/libbrotlienc.pc.in | ||
index 4dd0811b..2098afe2 100644 | ||
--- a/scripts/libbrotlienc.pc.in | ||
+++ b/scripts/libbrotlienc.pc.in | ||
@@ -7,6 +7,6 @@ Name: libbrotlienc | ||
URL: https://github.com/google/brotli | ||
Description: Brotli encoder library | ||
Version: @PACKAGE_VERSION@ | ||
-Libs: -L${libdir} -R${libdir} -lbrotlienc | ||
+Libs: -L${libdir} -lbrotlienc | ||
Requires.private: libbrotlicommon >= 1.0.2 | ||
Cflags: -I${includedir} |