Skip to content

Commit

Permalink
games-roguelike/zangband: remove games.eclass, update to EAPI 7
Browse files Browse the repository at this point in the history
TODO: figure out why DESTDIR is not respected
Signed-off-by: Wolfgang E. Sanyer <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
ezzieyguywuf authored and thesamesam committed Apr 5, 2021
1 parent 26aadfd commit 104ca58
Showing 1 changed file with 27 additions and 25 deletions.
52 changes: 27 additions & 25 deletions games-roguelike/zangband/zangband-2.7.4c.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
EAPI=7

inherit autotools eutils games
inherit autotools multilib

DESCRIPTION="An enhanced version of the Roguelike game Angband"
HOMEPAGE="http://www.zangband.org/"
Expand All @@ -25,39 +25,41 @@ DEPEND="${RDEPEND}

S=${WORKDIR}/${PN}

PATCHES=( "${FILESDIR}"/${P}-tk85.patch
"${FILESDIR}"/${P}-rng.patch
"${FILESDIR}"/${P}-tinfo.patch
"${FILESDIR}"/${P}-configure.patch
"${FILESDIR}"/${P}-makefile.patch )

src_prepare() {
epatch "${FILESDIR}"/${P}-tk85.patch \
"${FILESDIR}"/${P}-rng.patch \
"${FILESDIR}"/${P}-tinfo.patch \
"${FILESDIR}"/${P}-configure.patch \
"${FILESDIR}"/${P}-makefile.patch
default

mv configure.in configure.ac || die
eautoreconf
}

src_configure() {
egamesconf \
--datadir="${GAMES_DATADIR_BASE}" \
--with-setgid="${GAMES_GROUP}" \
--without-gtk \
local myconf=(
--libdir="${EPREFIX}"/$(get_libdir)/${PN}
--with-setgid="nobody"
--without-gtk
$(use_with tk tcltk)
)

econf "${myconf[@]}"
}

src_install() {
# Keep some important dirs we want to chmod later
keepdir "${GAMES_DATADIR}"/${PN}/lib/{apex,user,save,bone,info,xtra/help,xtra/music}
DOCS=( readme
z_faq.txt
z_update.txt )

src_install() {
# Install the basic files but remove unneeded crap
emake DESTDIR="${D}/${GAMES_DATADIR}"/${PN}/ installbase
rm "${D}${GAMES_DATADIR}"/${PN}/{angdos.cfg,readme,z_faq.txt,z_update.txt}
emake DESTDIR="${D}/" installbase
rm "${D}"/{angdos.cfg,readme,z_faq.txt,z_update.txt}

# Install everything else and fix the permissions
dogamesbin zangband
dodoc readme z_faq.txt z_update.txt
find "${D}${GAMES_DATADIR}/zangband/lib" -type f -exec chmod a-x \{\} +

prepgamesdirs
# All users in the games group need write permissions to
# some important dirs
fperms -R g+w "${GAMES_DATADIR}"/zangband/lib/{apex,data,save,user}
dobin zangband

einstalldocs
}

0 comments on commit 104ca58

Please sign in to comment.