Skip to content

Commit

Permalink
gnome-base/libgnomeprintui: Apply Magia patches for fixing multiple b…
Browse files Browse the repository at this point in the history
…ugs, also use system-config-printer optionally if it's present instead of silently dying, use adwaita-icon-theme and other fixes.

Package-Manager: portage-2.3.2
  • Loading branch information
pacho2 committed Dec 9, 2016
1 parent 989766e commit 1087707
Show file tree
Hide file tree
Showing 5 changed files with 125 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -up ./configure.in.orig ./configure.in
--- ./configure.in.orig 2014-05-04 11:07:55.308844477 +0300
+++ ./configure.in 2014-05-04 11:08:26.884571685 +0300
@@ -64,7 +64,7 @@ PKG_CHECK_MODULES(LIBGNOMEPRINTUI, [
gtk+-2.0 >= 2.6.0
libgnomeprint-2.2 >= 2.12.1
libgnomecanvas-2.0 >= 1.117.0
- gnome-icon-theme >= 1.1.92
+ adwaita-icon-theme >= 1.1.92
])
AC_SUBST(LIBGNOMEPRINTUI_CFLAGS)
AC_SUBST(LIBGNOMEPRINTUI_LIBS)
10 changes: 10 additions & 0 deletions gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-intl.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
--- libgnomeprintui-2.18.6/libgnomeprintui/gpaui/Makefile.am~ 2010-02-09 12:33:13.000000000 +0000
+++ libgnomeprintui-2.18.6/libgnomeprintui/gpaui/Makefile.am 2015-11-03 23:16:49.625137517 +0000
@@ -2,7 +2,6 @@

INCLUDES = \
-I$(top_srcdir) \
- -I$(top_srcdir)/intl \
-I$(top_srcdir)/libgnomeprintui \
-DWE_ARE_LIBGNOMEPRINT_INTERNALS \
$(LIBGNOMEPRINTUI_CFLAGS) \
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
--- ./libgnomeprintui/gnome-print-job-preview.c.orig 2012-02-23 22:48:42.000000000 +0600
+++ ./libgnomeprintui/gnome-print-job-preview.c 2012-02-25 00:18:43.000000000 +0600
@@ -152,6 +152,7 @@
GtkWidget *last;
GnomeCanvas *canvas;
GnomePrintConfig *config;
+ guchar *paper_orientation_save;

guint current_page, current_offset;

@@ -2187,6 +2188,19 @@
if (jp->config)
g_object_unref (G_OBJECT (jp->config));
jp->config = config;
+ if( config ) {
+ guchar *txt = gnome_print_config_get( jp->config, (const guchar*)GNOME_PRINT_KEY_PAGE_ORIENTATION );
+ if( ( g_ascii_strcasecmp(( const gchar* )txt, "R90") == 0 ) ||
+ ( g_ascii_strcasecmp(( const gchar* )txt, "R270") == 0 ) ) {
+ jp->paper_orientation_save =
+ gnome_print_config_get( jp->config, (const guchar*)GNOME_PRINT_KEY_PAPER_ORIENTATION );
+ gnome_print_config_set( jp->config, (const guchar*)GNOME_PRINT_KEY_PAPER_ORIENTATION, txt );
+ g_free ( txt );
+ }
+ else {
+ jp->paper_orientation_save = NULL;
+ }
+ }
if (!jp->config)
return;
g_object_ref (G_OBJECT (jp->config));
@@ -2389,6 +2403,13 @@
{
GnomePrintJobPreview *jp = GNOME_PRINT_JOB_PREVIEW (object);

+ if( jp->paper_orientation_save ) {
+ gnome_print_config_set( jp->config, (const guchar*)GNOME_PRINT_KEY_PAPER_ORIENTATION,
+ jp->paper_orientation_save );
+ g_free ( jp->paper_orientation_save );
+ jp->paper_orientation_save = NULL;
+ }
+
gnome_print_job_preview_set_config (jp, NULL);
gnome_print_job_preview_set_job (jp, NULL);

Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -p -up libgnomeprintui-2.18.3/libgnomeprintui/gnome-printer-selector.c.system-config-printer libgnomeprintui-2.18.3/libgnomeprintui/gnome-printer-selector.c
--- libgnomeprintui-2.18.3/libgnomeprintui/gnome-printer-selector.c.system-config-printer 2008-09-23 10:49:59.000000000 +0200
+++ libgnomeprintui-2.18.3/libgnomeprintui/gnome-printer-selector.c 2008-09-23 10:50:47.000000000 +0200
@@ -47,7 +47,7 @@
#include "gpaui/gpa-transport-selector.h"

#define GPS_PAD 4
-#define ADD_PRINTER_APP "gnome-cups-add"
+#define ADD_PRINTER_APP "system-config-printer"

static void gnome_printer_selector_class_init (GnomePrinterSelectorClass *klass);
static void gnome_printer_selector_init (GObject *object);
47 changes: 47 additions & 0 deletions gnome-base/libgnomeprintui/libgnomeprintui-2.18.6-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
GNOME_TARBALL_SUFFIX="bz2"

inherit gnome2 multilib-minimal

DESCRIPTION="User interface libraries for gnome print"
HOMEPAGE="https://www.gnome.org/"

LICENSE="GPL-2 LGPL-2.1"
SLOT="2.2"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
IUSE=""

RDEPEND="
>=gnome-base/libgnomeprint-2.12.1[${MULTILIB_USEDEP}]
>=gnome-base/libgnomecanvas-1.117[${MULTILIB_USEDEP}]
>=x11-libs/gtk+-2.6:2[${MULTILIB_USEDEP}]
x11-themes/adwaita-icon-theme
"
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig[${MULTILIB_USEDEP}]
"

src_prepare() {
# Patches from Mageia
eapply "${FILESDIR}"/${P}-adwaita-icon-theme.patch
eapply "${FILESDIR}"/${P}-intl.patch
eapply "${FILESDIR}"/${P}-orientation-for-preview.patch
eapply "${FILESDIR}"/${P}-system-config-printer.patch
eautoreconf
gnome2_src_prepare
}

multilib_src_configure() {
ECONF_SOURCE=${S} \
gnome2_src_configure \
--disable-static
}

multilib_src_install() {
gnome2_src_install
}

0 comments on commit 1087707

Please sign in to comment.