Skip to content

Commit

Permalink
games-action/descent2-demodata: Use arj instead of unarj, EAPI 7
Browse files Browse the repository at this point in the history
unarj has a problematic license. arj is better anyway as it handles
multiple volumes for us.

Bug: https://bugs.gentoo.org/694746
Package-Manager: Portage-3.0.5, Repoman-3.0.1
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
chewi committed Sep 5, 2020
1 parent 484f876 commit 1182457
Showing 1 changed file with 7 additions and 17 deletions.
24 changes: 7 additions & 17 deletions games-action/descent2-demodata/descent2-demodata-1.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

MY_PN="d2demo"
DEMO="${MY_PN}${PV//.}.zip"
Expand All @@ -17,27 +17,17 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="!<games-action/d2x-0.2.5-r3
!games-action/descent2-data"

DEPEND="app-arch/unzip
app-arch/unarj"
BDEPEND="app-arch/unzip
app-arch/arj"

S="${WORKDIR}"

src_unpack() {
default

# This is much more fun than simply downloading
# http://www.icculus.org/d2x/data/d2shar10.tar.gz
unarj e D2_1.SOW || die
mv ${MY_PN}.ham{,1} || die
unarj e D2_2.SOW || die
mv ${MY_PN}.ham{,2} || die
mv ${MY_PN}.pig{,2} || die
unarj e D2_3.SOW || die
mv ${MY_PN}.pig{,3} || die

# From the sows, big porkie pies shall grow
cat ${MY_PN}.ham{1,2} > ${MY_PN}.ham || die
cat ${MY_PN}.pig{2,3} > ${MY_PN}.pig || die
mv D2_2.SOW D2_1.S01 || die
mv D2_3.SOW D2_1.S02 || die
arj e -v -y -_ D2_1.SOW || die
}

src_install() {
Expand Down

0 comments on commit 1182457

Please sign in to comment.