Skip to content

Commit

Permalink
games-action/geki3-KXL: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.2.28
  • Loading branch information
austin987 committed Jul 6, 2016
1 parent d9c72ab commit 11db0f7
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 8 deletions.
16 changes: 8 additions & 8 deletions games-action/geki3-KXL/files/geki3-KXL-1.0.3-paths.patch
Original file line number Diff line number Diff line change
@@ -1,13 +1,13 @@
--- bmp/Makefile.am
+++ bmp/Makefile.am
--- a/bmp/Makefile.am
+++ b/bmp/Makefile.am
@@ -1,4 +1,4 @@
-bmpdir = $(prefix)/share/geki3/bmp
+bmpdir = $(BMP_PATH)
bmp_DATA = back1.bmp boss2.bmp enemyshot1.bmp missile.bmp\
pata.bmp back2.bmp boss3.bmp enemyshot2.bmp mogu.bmp\
pata_ball.bmp back3.bmp boss4.bmp frame.bmp mogu_ball.bmp\
--- configure.in
+++ configure.in
--- a/configure.in
+++ b/configure.in
@@ -25,9 +25,9 @@
BMP_PATH=/usr/local/share/geki3/bmp
WAV_PATH=/usr/local/share/geki3/wav
Expand All @@ -21,8 +21,8 @@
fi
AC_DEFINE_UNQUOTED(DATA_PATH,"$DATA_PATH")
AC_DEFINE_UNQUOTED(BMP_PATH,"$BMP_PATH")
--- data/Makefile.am
+++ data/Makefile.am
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,6 +1,4 @@
-datadir = $(prefix)/share/geki3/data
+datadir = $(DATA_PATH)
Expand All @@ -31,8 +31,8 @@

-install:
- $(INSTALL) -c -m 666 ./.score $(DESTDIR)$(DATA_PATH)
--- wav/Makefile.am
+++ wav/Makefile.am
--- a/wav/Makefile.am
+++ b/wav/Makefile.am
@@ -1,4 +1,4 @@
-wavdir = $(prefix)/share/geki3/wav
+wavdir = $(WAV_PATH)
Expand Down
53 changes: 53 additions & 0 deletions games-action/geki3-KXL/geki3-KXL-1.0.3-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit autotools eutils user

DESCRIPTION="2D length scroll shooting game"
HOMEPAGE="http://triring.net/ps2linux/games/kxl/kxlgames.html"
SRC_URI="mirror://gentoo/${P}.tar.gz
mirror://gentoo/${PN}.png"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="dev-games/KXL"
RDEPEND="${DEPEND}
media-fonts/font-adobe-100dpi"

PATCHES=(
"${FILESDIR}"/${P}-paths.patch
)

pkg_setup(){
enewgroup gamestat 36
}

src_prepare() {
default
rm -f missing
sed -i \
-e '1i #include <string.h>' \
-e "s:DATA_PATH \"/.score\":\"/var/games/${PN}\":" \
src/ranking.c || die
sed -i -e '/CFLAGS/s/$/ @CFLAGS@/' src/Makefile.am || die #bug 426890
mv configure.{in,ac}
eautoreconf
}

src_install() {
default

insinto /var/games/${PN}
newins data/.score ${PN}
fowners root:gamestat /var/games/${PN} /usr/bin/geki3
fperms 660 /var/games/${PN}
fperms 2755 /usr/bin/geki3

doicon "${DISTDIR}"/${PN}.png
make_desktop_entry geki3 Geki3
}

0 comments on commit 11db0f7

Please sign in to comment.