Skip to content

Commit

Permalink
dev-ml/alcotest: Bump to 0.8.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
aballier committed Jun 28, 2017
1 parent ef7a672 commit 11dddc8
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/alcotest/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST alcotest-0.7.2.tar.gz 24781 SHA256 75eac2c9b9c1f9e07d8c4de43ba8e852bd59ef1d7d322cd9c036a075335ef472 SHA512 3448c7d82c200f0cf2ac97f7f49060c350c0719124b24079b5babb48b1d3e0b0508ada0b273e1963dc07dc4cc072b0a589096c39b8b6d8a4adf7e011418dd4a3 WHIRLPOOL d1345d9c3481663fa29d99cf8483bc2e11251a088bd589472eb83f8483b7b3db6130098560de7cb3d00f0741c68c0d0060ae0b602a8f2af51950c0199b0ee612
DIST alcotest-0.8.0.tar.gz 24078 SHA256 623c045899aba9b10f30cf424e380611f866985ef4c35cd8dbf3b9c0beb926ee SHA512 7dda623557fea2961d255d5c90855a3dc02f2a578aa49660d8550832523bb318daa2af6eba83a92532a43914ef4c74e8446a5bbffa726993f0382142c7d5325c WHIRLPOOL d580317a6928b14e21c72589ff7820b5bc1e13dfdd7efe383b356b76f174c17138314a767d15d08503af30c6a99917d2c83e2001b12cafe702571aec535c0e69
46 changes: 46 additions & 0 deletions dev-ml/alcotest/alcotest-0.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"

DESCRIPTION="A lightweight and colourful test framework"
HOMEPAGE="https://github.com/mirage/alcotest/"
SRC_URI="https://github.com/mirage/alcotest/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="ISC"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="test"

RDEPEND="
dev-lang/ocaml:=[ocamlopt]
dev-ml/fmt:=
dev-ml/astring:=
dev-ml/cmdliner:=
dev-ml/result:=
"
DEPEND="${RDEPEND}
dev-ml/opam
dev-ml/jbuilder
dev-ml/findlib"

src_compile() {
jbuilder build -p alcotest || die
}

src_test() {
jbuilder runtest -p alcotest || die
}

oinstall() {
opam-installer -i \
--prefix="${ED}/usr" \
--libdir="${D}/$(ocamlc -where)" \
--docdir="${ED}/usr/share/doc/${PF}" \
--mandir="${ED}/usr/share/man" \
${1}.install || die
}

src_install() {
oinstall alcotest
}

0 comments on commit 11dddc8

Please sign in to comment.