Skip to content

Commit

Permalink
app-office/calligra: Fix build with poppler-0.82.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Nov 2, 2019
1 parent bc401f8 commit 11e22c2
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
4 changes: 4 additions & 0 deletions app-office/calligra/calligra-3.1.0-r4.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -135,6 +135,10 @@ pkg_setup() {
src_prepare() {
kde5_src_prepare

if has_version ">=app-text/poppler-0.82"; then
eapply "${FILESDIR}/${P}-poppler-0.82.patch" # TODO: make upstreamable patch
fi

if ! use test; then
sed -e "/add_subdirectory( *benchmarks *)/s/^/#DONT/" \
-i libs/pigment/CMakeLists.txt || die
Expand Down
35 changes: 35 additions & 0 deletions app-office/calligra/files/calligra-3.1.0-poppler-0.82.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
Patch stolen from Mageia Cauldron but had to be modified quite a bit.

diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
index ffdbf01..70bc9f8 100644
--- a/filters/karbon/pdf/SvgOutputDev.cpp
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
@@ -405,7 +405,7 @@ void SvgOutputDev::drawString(GfxState * state, GooString * s)
const char * p = s->c_str();
int len = s->getLength();
CharCode code;
- Unicode *u = nullptr;
+ const Unicode *u = nullptr;
int uLen;
double dx, dy, originX, originY;
while (len > 0) {
@@ -545,7 +545,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object */*ref*/, Stream *str,

void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
int width, int height, GfxImageColorMap *colorMap,
- bool /*interpolate*/, int *maskColors, bool inlineImg)
+ bool /*interpolate*/, const int *maskColors, bool inlineImg)
{
drawImage(state, ref, str, width, height, colorMap, maskColors, inlineImg);
}
--- a/filters/karbon/pdf/SvgOutputDev.h
+++ b/filters/karbon/pdf/SvgOutputDev.h
@@ -63,7 +63,7 @@ public:
// images
void drawImage(GfxState *state, Object *ref, Stream *str,
int width, int height, GfxImageColorMap *colorMap,
- bool interpolate, int *maskColors, bool inlineImg) override;
+ bool interpolate, const int *maskColors, bool inlineImg) override;

// styles
virtual void updateAll(GfxState *state);

0 comments on commit 11e22c2

Please sign in to comment.