Skip to content

Commit

Permalink
net-misc/omniORB: add 4.2.4
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/787110
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed May 10, 2021
1 parent 63dcc0e commit 1247e22
Show file tree
Hide file tree
Showing 2 changed files with 93 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/omniORB/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST omniORB-4.2.2.tar.bz2 2673800 BLAKE2B 6afe4759cf19b69bd02d4864e305a0ebd0d11943a54c20d53987d9775f04833d5d2dbeb99e5bdcc59d56f116cfb14b9ae92399323e3980a44d9cef47a012c24f SHA512 3fe6c05d0e7f19455c4cd6702887f91b7d14cdc248008cbc456c103072a37251387877bd64d59a271c6e92703a70bbbb9713f9fa2e45d094628e42564cffd0ad
DIST omniORB-4.2.4.tar.bz2 2713397 BLAKE2B 5759b2563dca421b9a994bb13c30ce6dd98324a2357c4908130a42ce5baec357b881c22b4dff27809607ebde27e7cd65305a91aa5cbdb6d68a19df1f36524e72 SHA512 0b142b127175f16f844823e5adf5593b290528646e13a4c30f6cbd92d159d3998a81b952717039c3f0e386f79404ddd18a3de35fc45fa88383d1d9e51064d988
92 changes: 92 additions & 0 deletions net-misc/omniORB/omniORB-4.2.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,92 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7,8,9} )

inherit python-single-r1

MY_P="${P/_p/-}"
DESCRIPTION="A robust, high-performance CORBA 2 ORB"
HOMEPAGE="http://omniorb.sourceforge.net/"
SRC_URI="mirror://sourceforge/omniorb/${MY_P}.tar.bz2"

LICENSE="LGPL-2 GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc ipv6 ssl"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
ssl? ( dev-libs/openssl:0= )"
DEPEND="${RDEPEND}"

src_prepare() {
default

# The OPTC(XX)FLAGS variables aren't present in these files, but we
# will set them when we call emake.
sed \
-e 's/^CXXDEBUGFLAGS.*/CXXDEBUGFLAGS = $(OPTCXXFLAGS)/' \
-e 's/^CDEBUGFLAGS.*/CDEBUGFLAGS = $(OPTCFLAGS)/' \
-i mk/beforeauto.mk.in mk/platforms/i586_linux_2.0*.mk || \
die "failed to switch CFLAGS variables in the makefile includes"

# The out-of-source build is suggested by upstream.
mkdir build || die "failed to create build directory"
}

src_configure() {
cd build || die "failed to change into the build directory"

ECONF_SOURCE=".." econf \
--disable-static \
--with-omniORB-config=/etc/omniorb/omniORB.cfg \
--with-omniNames-logdir=/var/log/omniORB \
--libdir="/usr/$(get_libdir)" \
$(use_enable ipv6) \
$(use_with ssl openssl "/usr")
}

src_compile() {
cd build || die "failed to change into the build directory"
emake OPTCFLAGS="${CFLAGS}" OPTCXXFLAGS="${CXXFLAGS}"
}

src_install() {
cd build || die "failed to change into the build directory"
default

rm "${ED}/usr/bin/omniidlrun.py" || \
die "failed to remove redundant omniidlrun.py"

cd "${S}" || die "failed to change into the ${S} directory"

dodoc CREDITS doc/*.html ReleaseNotes.txt update.log
dodoc -r doc/omniORB

if use doc; then
dodoc doc/*.pdf
fi

cat <<- EOF > "${T}/90omniORB"
PATH="/usr/share/omniORB/bin/scripts"
OMNIORB_CONFIG="/etc/omniorb/omniORB.cfg"
EOF
doenvd "${T}/90omniORB"
doinitd "${FILESDIR}"/omniNames

cp "sample.cfg" "${T}/omniORB.cfg" || die
cat <<- EOF >> "${T}/omniORB.cfg"
# resolve the omniNames running on localhost
InitRef = NameService=corbaname::localhost
EOF
insinto /etc/omniorb
doins "${T}"/omniORB.cfg

keepdir /var/log/omniORB

python_optimize
python_fix_shebang "${ED}"/usr/bin/omniidl
}

0 comments on commit 1247e22

Please sign in to comment.