Skip to content

Commit

Permalink
net-libs/nodejs: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
patricklauer committed Feb 9, 2016
1 parent 1eb96ce commit 1256083
Show file tree
Hide file tree
Showing 2 changed files with 187 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-libs/nodejs/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST node-v4.2.2.tar.xz 12791572 SHA256 b016c3d2f434f86d8d3da9ad90ffb2fd35b32223
DIST node-v5.0.0.tar.xz 12863764 SHA256 cf4f261618e19517c8cbf2fdde00d0b5160e271760abee00f387b11a0b3ca834 SHA512 5b07af6b77a25924e3028257a511f035df943b854c694168e24c20f6aa735cde72546fc231d63a491367e16232ee9b6622d1f748624bf3e99e0d0468528e96c3 WHIRLPOOL 8958da059e0bc8e196d9b5f1b079f6d1927a3707b466fdc6e87ece676f981a7f22c4fa485bdb6de9879305cf2deb578d49840dee6d69d1cddba698e070b19923
DIST node-v5.3.0.tar.xz 12776504 SHA256 e5115ee78c31ac3af0f2b3553aa84fff2f49ae59bd6e01e11d78ce86c544569e SHA512 f65773c35ce774bc6fe242f8627e5786f441f0286f7d272e854e2e2d6b927d5f368c366ff52dd780f7817fedf3935ec25e78ed3f81d4613495663eb81e2afbb1 WHIRLPOOL 5f270ed6fe35dba091bd75e6ad9de419c781fc6f919915a4117b8c0bbb2ea11a05369a9149e4f69614de508ff109eb94b24bdafc0832e91e055f01b0ef214c67
DIST node-v5.4.1.tar.xz 12812444 SHA256 4e7d3fdfeac85c46ddaef0224695620f218e7a178e97d6e210d6d643483f1d53 SHA512 9803478d502bf11bfc77e56109568b0f64186826be35a9b36b47b63ec744595db128955e6f7bec7eb4db39e85afdd364b1215427954ce33ab67689ff03a5bc57 WHIRLPOOL 87f791f4f0722a2d3bcb630d22548f395ac0e86dedc37849caab2d63bc43bad2621058f95eb2b31b1f3b01ec8585c0731c969a1f0167d95495008b44f3b69066
DIST node-v5.5.0.tar.xz 13059924 SHA256 9c46b4dc9548e43826f71f6571f56e39783c456b9516045b496ea73321731e22 SHA512 8a2d268db2e04d905f879d3b1c1a9a17fb060754ccde86680df85311babf033249730e0ab3f7bd131b16ddaf79d740556e3ee4f37f34a0754be7d9c9080fa683 WHIRLPOOL baf2ec5dc3929a642487d83ebe2e442111379b841b7a2349ba17f372f420f40d4a069098909bffd85ed9e3f34d970ecf542cc80b0df3aac5470c656206cdc481
186 changes: 186 additions & 0 deletions net-libs/nodejs/nodejs-5.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,186 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"

inherit bash-completion-r1 eutils flag-o-matic pax-utils python-single-r1 toolchain-funcs

DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"

LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
IUSE="cpu_flags_x86_sse2 debug doc icu +npm +snapshot +ssl test"

RDEPEND="icu? ( >=dev-libs/icu-56:= )
${PYTHON_DEPS}
>=net-libs/http-parser-2.6:=
>=dev-libs/libuv-1.8.0:=
>=dev-libs/openssl-1.0.2e:0=[-bindist]
sys-libs/zlib"
DEPEND="${RDEPEND}
!!net-libs/iojs
test? ( net-misc/curl )"

S="${WORKDIR}/node-v${PV}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

pkg_pretend() {
(use x86 && ! use cpu_flags_x86_sse2) && \
die "Your CPU doesn't support the required SSE2 instruction."

if [[ ${MERGE_TYPE} != "binary" ]] ; then
if ! test-flag-CXX -std=c++11 ; then
die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 3.3 or newer."
fi
fi
}

src_prepare() {
tc-export CC CXX PKG_CONFIG
export V=1
export BUILDTYPE=Release

# fix compilation on Darwin
# https://code.google.com/p/gyp/issues/detail?id=260
sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die

# make sure we use python2.* while using gyp
sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
sed -i -e "s/|| 'python'/|| '${EPYTHON}'/" deps/npm/node_modules/node-gyp/lib/configure.js || die

# less verbose install output (stating the same as portage, basically)
sed -i -e "/print/d" tools/install.py || die

# proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
local LIBDIR=$(get_libdir)
sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
sed -i -e "s/'lib'/'${LIBDIR}'/" lib/module.js || die
sed -i -e "s|\"lib\"|\"${LIBDIR}\"|" deps/npm/lib/npm.js || die

# Avoid writing a depfile, not useful
sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die

# Avoid a test that I've only been able to reproduce from emerge. It doesnt
# seem sandbox related either (invoking it from a sandbox works fine).
# The issue is that no stdin handle is openened when asked for one.
# It doesn't really belong upstream , so it'll just be removed until someone
# with more gentoo-knowledge than me (jbergstroem) figures it out.
rm test/parallel/test-stdout-close-unref.js || die

# debug builds. change install path, remove optimisations and override buildtype
if use debug; then
sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
BUILDTYPE=Debug
fi

epatch_user
}

src_configure() {
local myarch=""
local myconf=( --shared-openssl --shared-libuv --shared-http-parser --shared-zlib )
use npm || myconf+=( --without-npm )
use icu && myconf+=( --with-intl=system-icu )
use snapshot && myconf+=( --with-snapshot )
use ssl || myconf+=( --without-ssl )
use debug && myconf+=( --debug )

case ${ABI} in
x86) myarch="ia32";;
amd64) myarch="x64";;
x32) myarch="x32";;
arm) myarch="arm";;
arm64) myarch="arm64";;
*) die "Unrecognized ARCH ${ARCH}";;
esac

GYP_DEFINES="linux_use_gold_flags=0
linux_use_bundled_binutils=0
linux_use_bundled_gold=0" \
"${PYTHON}" configure \
--prefix="${EPREFIX}"/usr \
--dest-cpu=${myarch} \
--without-dtrace \
"${myconf[@]}" || die
}

src_compile() {
emake -C out mksnapshot
pax-mark m "out/${BUILDTYPE}/mksnapshot"
emake -C out

use doc && emake doc
}

src_install() {
local LIBDIR="${ED}/usr/$(get_libdir)"
make install DESTDIR="${ED}" PREFIX=/usr
pax-mark -m "${ED}"usr/bin/node

# set up a symlink structure that npm expects..
dodir /usr/include/node/deps/{v8,uv}
dosym . /usr/include/node/src
for var in deps/{uv,v8}/include; do
dosym ../.. /usr/include/node/${var}
done

if use doc; then
# Patch docs to make them offline readable
for i in `grep -rl 'fonts.googleapis.com' "${S}"/out/doc/api/*`; do
sed -i '/fonts.googleapis.com/ d' $i;
done
# Install docs!
dohtml -r "${S}"/out/doc/api/*
fi

if use npm; then
# Install bash completion for `npm`
local tmp_npm_completion_file="$(emktemp)"
"${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
newbashcomp "${tmp_npm_completion_file}" npm
rm "${LIBDIR}"/node_modules/npm/lib/utils/completion.sh

# Move man pages
doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*

# Clean up
rm "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile} || die
rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man} || die

local temp_name=("'AUTHORS*'" "'CHANGELOG*'" "'CONTRIBUT*'" \
"'README*'" "'.travis.yml'" "'.eslint*'" "'.wercker.yml'" \
"'.npmignore'" "'*.md'" "'*.markdown'" "'*.bat'" "'*.cmd'")
local find_exp="-or -name"
local find_name=( "${temp_name[@]/%/ ${find_exp}}" )
# drop last "-or -name"
find_name[-1]="${find_name[-1]%${find_exp}}"
local find_iname="-iname 'LICEN?E*' ${find_exp}"

# Remove various development and/or inappropriate files and
# useless docs of dependend packages.
find "${LIBDIR}"/node_modules \
\( -type d -name examples \) -or \( -type f \( \
${find_iname} ${find_name[@]} \
\) \)
eend $?
fi
}

src_test() {
out/${BUILDTYPE}/cctest || die
"${PYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
}

pkg_postinst() {
einfo "When using node-gyp to install native modules, you can avoid"
einfo "having to download the full tarball by doing the following:"
einfo ""
einfo "node-gyp --nodedir /usr/include/node <command>"
}

0 comments on commit 1256083

Please sign in to comment.