Skip to content

Commit

Permalink
dev-scheme/guile: fix compilation on Darwin, thanks * in bug #612338
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
grobian committed Jun 21, 2017
1 parent 1d9b81f commit 13a0978
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 1 deletion.
38 changes: 38 additions & 0 deletions dev-scheme/guile/files/guile-2.0.14-darwin.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
fix compilation on Darwin

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=24862#23
https://bugs.gentoo.org/show_bug.cgi?id=612338

--- guile-2.0.14/libguile/filesys.c
+++ guile-2.0.14/libguile/filesys.c
@@ -1486,6 +1486,9 @@
mode_bits = scm_i_mode_bits (mode);
}

+#ifdef __APPLE__
+ open_flags &= O_APPEND|O_SHLOCK|O_EXLOCK|O_CLOEXEC;
+#endif
SCM_SYSCALL (rv = mkostemp (c_tmpl, open_flags));
if (rv == -1)
SCM_SYSERROR;
--- guile-2.0.14/libguile/stime.c
+++ guile-2.0.14/libguile/stime.c
@@ -830,6 +830,10 @@

#ifdef HAVE_POSIX_CPUTIME
{
+#ifdef __APPLE__
+ if (clock_gettime (CLOCK_PROCESS_CPUTIME_ID, &posix_run_time_base) == 0)
+ get_internal_run_time = get_internal_run_time_posix_timer;
+#else
clockid_t dummy;

/* Only use the _POSIX_CPUTIME clock if it's going to work across
@@ -839,6 +843,7 @@
get_internal_run_time = get_internal_run_time_posix_timer;
else
errno = 0;
+#endif
}
#endif /* HAVE_POSIX_CPUTIME */
#endif /* HAVE_CLOCKTIME */
5 changes: 4 additions & 1 deletion dev-scheme/guile/guile-2.0.14.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -32,7 +32,10 @@ MAJOR="2.0"

DOCS=( GUILE-VERSION HACKING README )

PATCHES=( "${FILESDIR}/${PN}-2-snarf.patch" )
PATCHES=(
"${FILESDIR}/${PN}-2-snarf.patch"
"${FILESDIR}/${P}-darwin.patch"
)

src_prepare() {
default
Expand Down

0 comments on commit 13a0978

Please sign in to comment.