Skip to content

Commit

Permalink
media-plugins/vdr-streamdev: new snapshot, support >=vdr-2.3.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
  • Loading branch information
hd-brummy committed May 30, 2016
1 parent ef28c63 commit 13f1e8d
Show file tree
Hide file tree
Showing 2 changed files with 100 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-plugins/vdr-streamdev/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST vdr-plugin-streamdev-674bb5b331240de3ba2a8beb63a1276003e64e3e.tar.bz2 163096 SHA256 5a9fa7ba82fe40b0380e76c94814c662cc82486cd6097710a9c8857307ac4970 SHA512 f9439a4c3dd453869f9cf3171ddb5e34c2a625d7873cb1648138e4b94715ec3acd8d3db69df5ae5bf1bc21f0401f9b12a126395b0f2696c129ee7725c1715902 WHIRLPOOL 30269bc0938ef5b6ac85e85bad85f34e9c6d8e1a704ab1bf18d156bb2d5fa4b7b24c1126c95d12e94946981e5274e137a347d3faa04e915a3a8015ca16e98894
DIST vdr-streamdev-0.6.1.tgz 186546 SHA256 b3ea814a572eb17699df4ae2a90a1ad6c22c0a68a8235e7f7ccf299d1ed43955 SHA512 bbe6231bd8e69e299c8d94173e7ed4b1f49e5b17b7bcadf2d1e827b5e8dd57c6b975c8c409fd44f252110099b3565a7d4d8c2f7d03636fc2d2e3580d0050d971 WHIRLPOOL e226ddbec680bb43857f96ae1553b71d218f87593cf179c65919444c19aa26392e42ef9dbe8607ddffc81ce781cb5a8b60123650a14be7c0997bc605b066c9f7
99 changes: 99 additions & 0 deletions media-plugins/vdr-streamdev/vdr-streamdev-0.6.1_p20160320.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,99 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit vdr-plugin-2

GIT_VERSION="674bb5b331240de3ba2a8beb63a1276003e64e3e"

DESCRIPTION="VDR Plugin: Client/Server and http streaming plugin"
HOMEPAGE="http://projects.vdr-developer.org/projects/plg-streamdev"
SRC_URI="http://projects.vdr-developer.org/git/vdr-plugin-streamdev.git/snapshot/vdr-plugin-streamdev-${GIT_VERSION}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="client +server"

DEPEND=">=media-video/vdr-1.7.25"
RDEPEND="${DEPEND}"

S="${WORKDIR}/vdr-plugin-streamdev-${GIT_VERSION}"

REQUIRED_USE="|| ( client server )"

# vdr-plugin-2.eclass changes
PO_SUBDIR="client server"

src_prepare() {
# make detection in vdr-plugin-2.eclass for new Makefile handling happy
echo "# SOFILE" >> Makefile

# rm unneeded entry
sed -i Makefile -e "s:-I\$(VDRDIR)/include::"

vdr-plugin-2_src_prepare

for flag in client server; do
if ! use ${flag}; then
sed -i Makefile \
-e '/^.PHONY:/s/'${flag}'//' \
-e '/^.PHONY:/s/'install-${flag}'//' \
-e '/^all:/s/'${flag}'//' \
-e '/^install:/s/'install-${flag}'//'
fi
done

fix_vdr_libsi_include server/livestreamer.c
}

src_install() {
vdr-plugin-2_src_install

if use server; then
insinto /usr/share/vdr/streamdev
doins streamdev-server/externremux.sh

insinto /usr/share/vdr/rcscript
newins "${FILESDIR}"/rc-addon-0.6.0.sh plugin-streamdev-server.sh

insinto /etc/conf.d
newins "${FILESDIR}"/confd-0.6.0 vdr.streamdev-server

insinto /etc/vdr/plugins/streamdev-server
newins streamdev-server/streamdevhosts.conf streamdevhosts.conf
fowners vdr:vdr /etc/vdr -R
fi
}

pkg_preinst() {
has_version "<${CATEGORY}/${PN}-0.6.0"
previous_less_than_0_6_0=$?
}

pkg_postinst() {
vdr-plugin-2_pkg_postinst

if [[ -e "${ROOT}"/etc/vdr/plugins/streamdev/streamdevhosts.conf ]]; then
einfo "move config file to new config DIR ${ROOT}/etc/vdr/plugins/streamdev-server/"
mv "${ROOT}"/etc/vdr/plugins/streamdev/streamdevhosts.conf "${ROOT}"/etc/vdr/plugins/streamdev-server/streamdevhosts.conf
fi

if [[ $previous_less_than_0_6_0 = 0 ]]; then
einfo "The server-side setting \"Suspend behaviour\" has been dropped in 0.6.0 in favour"
einfo "of priority based precedence. A priority of 0 and above means that clients"
einfo "have precedence. A negative priority gives precedence to local live TV on the"
einfo "server. So if \"Suspend behaviour\" was previously set to \"Client may suspend\" or"
einfo "\"Never suspended\", you will have to configure a negative priority. If the"
einfo "\"Suspend behaviour\" was set to \"Always suspended\", the default values should do."
einfo ""
einfo "Configure the desired priorities for HTTP and IGMP Multicast streaming in the"
einfo "settings of streamdev-server. If you haven't updated all your streamdev-clients"
einfo "to at least 0.5.2, configure \"Legacy Client Priority\", too."
einfo ""
einfo "In streamdev-client, you should set \"Minimum Priority\" to -99. Adjust \"Live TV"
einfo "Priority\" if necessary."
fi
}

0 comments on commit 13f1e8d

Please sign in to comment.