forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/docker-runc: Update snapshot
Package-Manager: Portage-2.3.8, Repoman-2.3.3
- Loading branch information
Showing
2 changed files
with
60 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST docker-runc-1.0.0_rc2_p20170308.tar.gz 561400 SHA256 bdd0fc0b5db42bb1fc439d5a5d6347d97b285e676559afb620ffd9f62fc1de26 SHA512 f17c7ff09578573a161f14616446e74d92d66039c1462bce23ea507b151eb66ede12d2ca583d3dace21d186a80bdadf222fc180bf1123e29c68e43f2f2d949c8 WHIRLPOOL f6853ccdd09ca1481828b20e64403151cd9c5d46ceb81c50e884d47e18f8594c21bf53102b252852b259b6b0186f54f070fb7f3c7e4447123cbf05aa69233035 | ||
DIST docker-runc-1.0.0_rc3_p20170607.tar.gz 1043233 SHA256 b363764efc58fc25757b71b8f64569f1f1f81f0beaa5cc3542ed7d602f15fa75 SHA512 53b9bc1ffd0c76e886a0eb9d9f0c78238b5bd7ca59884138c0ef438322b3b3b09d58a36e0fec8f6daa8b465323b7dc38515a915945f2009233e343b2ec3eca14 WHIRLPOOL f6069ea7cb9100be36ad40fbd24a46de65837e2408dd045fbb69aa6c6442f0ac662feba8f61caf21ef0aec1fcfed3a47b60e87f179012580d46e3dd041865f32 | ||
DIST docker-runc-1.0.0_rc3_p20170706.tar.gz 1042839 SHA256 d09b31b9a5adf0a3295d10b20e5f65ec8e1c52a371d463218694c37e075829e9 SHA512 8e937e8ccaa114913d61a450b030496668c1e2d80eecccf5e4914c5685d7dde9a0d50bc2aef9be844dc69eab81621aa1c043abbc72ba28ab6bdb9db5e86daeaf WHIRLPOOL bec7b506a6b2522d401733b32a9f500aec69920dc6d8072ab434c7bfbb1c88a6fb00afa1d2728f78fbaac1d58f890a2b5932fdbe2b0e87b749293f2b48ed2e8a |
59 changes: 59 additions & 0 deletions
59
app-emulation/docker-runc/docker-runc-1.0.0_rc3_p20170706.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,59 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
EGO_PN="github.com/opencontainers/${PN/docker-}" | ||
|
||
if [[ ${PV} == *9999 ]]; then | ||
inherit golang-vcs | ||
else | ||
MY_PV="${PV/_/-}" | ||
EGIT_COMMIT="810190ceaa507aa2727d7ae6f4790c76ec150bd2" | ||
RUNC_COMMIT="810190" # Change this when you update the ebuild | ||
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm ~ppc64" | ||
inherit golang-vcs-snapshot | ||
fi | ||
|
||
DESCRIPTION="runc container cli tools (docker fork)" | ||
HOMEPAGE="http://runc.io" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="apparmor ambient hardened +seccomp" | ||
|
||
RDEPEND=" | ||
apparmor? ( sys-libs/libapparmor ) | ||
seccomp? ( sys-libs/libseccomp ) | ||
!app-emulation/runc | ||
" | ||
|
||
S=${WORKDIR}/${P}/src/${EGO_PN} | ||
|
||
RESTRICT="test" | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e "s/git rev-parse.*\$/echo gentoo)/" -e "/COMMIT :=/d" -e "/COMMIT_NO :=/d" Makefile || die | ||
} | ||
|
||
src_compile() { | ||
# Taken from app-emulation/docker-1.7.0-r1 | ||
export CGO_CFLAGS="-I${ROOT}/usr/include" | ||
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '') | ||
-L${ROOT}/usr/$(get_libdir)" | ||
|
||
# build up optional flags | ||
local options=( | ||
$(usex apparmor 'apparmor' '') | ||
$(usex ambient 'ambient' '') | ||
$(usex seccomp 'seccomp' '') | ||
) | ||
|
||
GOPATH="${WORKDIR}/${P}" emake BUILDTAGS="${options[*]}" \ | ||
COMMIT="${RUNC_COMMIT}" | ||
} | ||
|
||
src_install() { | ||
dobin runc | ||
} |