Skip to content

Commit

Permalink
dev-vcs/git-flow: EAPI 6
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
johu committed Jan 9, 2016
1 parent 4ab1ec4 commit 143c670
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 1 deletion.
2 changes: 1 addition & 1 deletion dev-vcs/git-flow/git-flow-1.8.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down
40 changes: 40 additions & 0 deletions dev-vcs/git-flow/git-flow-1.8.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

MY_PN="${PN/-/}"
COMP_PN="${PN}-completion"
COMP_PV="0.5.1"
COMP_P="${COMP_PN}-${COMP_PV}"
inherit bash-completion-r1

DESCRIPTION="Git extensions to provide high-level repository operations for Vincent Driessen's branching model"
HOMEPAGE="https://github.com/petervanderdoes/gitflow"
SRC_URI="https://github.com/petervanderdoes/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
https://github.com/petervanderdoes/${COMP_PN}/archive/${COMP_PV}.tar.gz -> ${COMP_P}.tar.gz"

LICENSE="BSD MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND=""
RDEPEND="${DEPEND}
dev-vcs/git
"

DOCS=( AUTHORS Changes.mdown README.mdown )

S="${WORKDIR}/${MY_PN}-${PV}"

src_compile() {
true
}

src_install() {
emake prefix="${D}/usr" install
einstalldocs
newbashcomp "${WORKDIR}/${COMP_P}/${COMP_PN}.bash" ${PN}
}

0 comments on commit 143c670

Please sign in to comment.