Skip to content

Commit

Permalink
net-p2p/xmr-stak: 2.4.2 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.28, Repoman-2.3.9
  • Loading branch information
candrews committed Apr 5, 2018
1 parent 95b6110 commit 148876a
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-p2p/xmr-stak/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST xmr-stak-2.2.0.tar.gz 316309 BLAKE2B 8a5042e91eff1d7a49dcf50d67430f21459509443117150f59f861edb0c145e0f336cb617ea4f2a7edfd923493efbc8f5ce9cd134a7f7af14b270c8cfdd3cc24 SHA512 1ec30b1f97043307461816e61cb7afaf9e77cfad895b13f5facf98f34da8d9b8751d9885930b0a38777017978fb4f25bb3a69a1c2a5db47b1a851bc88cd7d78d
DIST xmr-stak-2.3.0.tar.gz 333364 BLAKE2B f8824f545ea08267eb9f670f2aaba7cb2e98693e5603dee5fbe54bb3f3ebc21509f26bb0d10239b79675e3ce32a2f4b32b591fb3af51b4c716fbb84beeb7326e SHA512 2828789ac63ab3cb13e36c6f86d9cf82f21f15f51df873a8a3e42757d16357653823d28103f2a076afa67ce7ca277ec92c5aee25fc823806e85c3a8c80b4ae5d
DIST xmr-stak-2.4.1.tar.gz 333961 BLAKE2B 0c58a705d601b6ff47329fad175580edf6a1d36704fa7d8f9d7464da65b8a69173c39caaaf9dccb031a514a8bcc29642ae531ae4f03c5d1c83f1c0e0177fd1aa SHA512 83f2fad93367cf3bdcc7c127bdf5df2b0467c85049fefe25a3394e8a6d4ae3a2fdabde949106f29204d48e46fc367bbc9d1fed295ce4fb376d8c23007251f926
DIST xmr-stak-2.4.2.tar.gz 334041 BLAKE2B 7d37ffd2e3d5f8a25692fe2ebdc8a75242fb02e614c3fa570722739cf279376882d4b84f6877ade4b62072d65a4fe7f726951c3cfa06d537986cd9a63386d391 SHA512 de1b9f8c3b839227a6a9ae08009c4bb50aa9714cd563721f2244b7a87af5ffe8a6691c29c247bba02223c8b8a8b8db25d14d104b97fdf908f0f2ad9a38f27653
65 changes: 65 additions & 0 deletions net-p2p/xmr-stak/xmr-stak-2.4.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils systemd

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/fireice-uk/xmr-stak.git"
EGIT_BRANCH="dev"
inherit git-r3
SRC_URI=""
else
SRC_URI="https://github.com/fireice-uk/xmr-stak/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

DESCRIPTION="Unified all-in-one Monero miner"
HOMEPAGE="https://github.com/fireice-uk/xmr-stak"
LICENSE="GPL-3"
SLOT="0"
IUSE="cuda devfee hwloc opencl ssl webserver"

DEPEND="cuda? ( dev-util/nvidia-cuda-toolkit )
hwloc? ( sys-apps/hwloc )
opencl? ( virtual/opencl )
ssl? ( dev-libs/openssl:0= )
webserver? ( net-libs/libmicrohttpd )"
RDEPEND="${DEPEND}"

src_prepare() {
cmake-utils_src_prepare
if ! use devfee; then
sed -i -e 's!fDevDonationLevel = .*;!fDevDonationLevel = 0.0;!' xmrstak/donate-level.hpp || die
fi
}

src_configure() {
local mycmakeargs=(
-DCUDA_ENABLE=$(usex cuda)
-DHWLOC_ENABLE=$(usex hwloc)
-DMICROHTTPD_ENABLE=$(usex webserver)
-DOpenCL_ENABLE=$(usex opencl)
-DOpenSSL_ENABLE=$(usex ssl)
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
systemd_newunit "${FILESDIR}"/${PN}-2.3.0.service ${PN}.service
dodir /etc/xmr-stak
}

pkg_postinst() {
if [ ! -e "${ROOT}etc/xmr-stak/main.config" ]; then
ewarn "To use xmr-stack:"
if use cuda || use opencl; then
ewarn "As root or as a user that is a member of the 'video' group,"
fi
ewarn "run:"
ewarn "/usr/bin/xmr-stak --cpu /etc/xmr-stak/cpu.config --amd /etc/xmr-stak/amd.config --nvidia /etc/xmr-stak/nvidia.config -c /etc/xmr-stak/main.config"
ewarn "If the systemd will be used, xmr-stak can now be terminated and 'systemctl start xmr-stak' can be used."
fi
}

0 comments on commit 148876a

Please sign in to comment.