Skip to content

Commit

Permalink
dev-ruby/fast_gettext: add 2.0.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Feb 6, 2020
1 parent 6544194 commit 14ec128
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/fast_gettext/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST fast_gettext-1.6.0.tar.gz 88780 BLAKE2B 237a37bf505fe7520a25c6014f052420190
DIST fast_gettext-1.8.0.tar.gz 89309 BLAKE2B 8ead2922662667c24d07dbc1145002583b1a65edd3cb581ac5bc058560aca38ed083e0470d4834cfdc5abae36f1e8264171b75649343675ab415b28ea2f0e8ab SHA512 0657b5955268166787a32bb74481cd07309018429c21707e061e022d67d5d2448d2d173149f164d16ff5f6c9ffa0feef38369b79daa299e1283fdcdc019ad72e
DIST fast_gettext-2.0.0.tar.gz 91904 BLAKE2B fc0f752cad55512f502332a8721aa64fe1b3103ecedceac08b82f293575e974e0565b2936ae740e61ef3413919406959c6a78709ddc737b3e7decd710eafbd46 SHA512 f997a63ecccc3a8836e191b8cdcb5ba0e260bedef4cc55efeecb12c1fb3a469cc98e9e565ac773392a2bdf266618a76c8d34b0522d5447967fb85f4dfeea3c10
DIST fast_gettext-2.0.1.tar.gz 92037 BLAKE2B 109470cb8ede188a7603dca9b79d17066b6fbbcfa13e2cb6b9a5a6f329d1285a042e152b5afaba206ac447fdbdbdb59f79b74ee2ac70ea39a99691a00fc82155 SHA512 edf98e22a39266c55e7d77547fb1b8cb3a07dcb7bd742e2eb93b636072902f065dede0d980bd3a67373f5afeacc39689cbcee33dd62ad10e1e94f6d84bcbc70c
DIST fast_gettext-2.0.2.tar.gz 92030 BLAKE2B 762f5e5375f29abb6477579aae25c023e7b5db27a41b857523baa3412f8f80f26fc9334ce0937de20cefcf9d845846a362e34540bc5817e9e8ad00c6a7abea8e SHA512 027b35c5d8f93719fbc14cbcd0843f2a0948b49c9cf2fb65e723ba410e6c0c14ce3e42c5ce7abe657946a7da2d20665559b71df1b9855c9a04978946a50beb51
60 changes: 60 additions & 0 deletions dev-ruby/fast_gettext/fast_gettext-2.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

USE_RUBY="ruby24 ruby25 ruby26 ruby27"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_GEMSPEC="fast_gettext.gemspec"

inherit ruby-fakegem

DESCRIPTION="GetText but 3.5x faster, 560x less memory, clean namespace and threadsave!"
HOMEPAGE="https://github.com/grosser/fast_gettext"
SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="public-domain"
SLOT="2"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
IUSE=""

ruby_add_bdepend "test? ( dev-ruby/bundler )"

all_ruby_prepare() {
rm Gemfile.lock || die

# Remove jeweler and bump from Gemfile since they are not needed for tests.
sed -i -e '/jeweler/d' -e '/bump/d' -e '/appraisal/d' Gemfile || die
sed -i -e '/single/I s:^:#:' spec/spec_helper.rb || die
sed -i -e '/SingleCov/ s:^:#:' spec/{*,*/*}/*spec.rb || die

# Avoid unneeded dependency on git and development dependencies.
sed -e '/git ls-files/ s:^:#:' \
-e '/\(wwtd\|bump\|sqlite3\|activerecord\|i18n\|single_cov\|forking_test_runner\|rubocop\)/ s:^:#:' \
-e 's:require_relative ":require "./:' \
-i fast_gettext.gemspec || die

# Avoid a test dependency on activerecord since this is now in the
# dependency tree for app-admin/puppet and many arches don't have
# rails keyworded.
sed -i -e '/active_record/ s:^:#:' spec/spec_helper.rb || die
rm -f spec/fast_gettext/translation_repository/db_spec.rb || die
rm -f spec/fast_gettext/storage_spec.rb || die
sed -i -e '/with i18n loaded/,/^ end/ s:^:#:' spec/fast_gettext/vendor/string_spec.rb || die

# Don't run a test that requires safe mode which we can't provide
# due to insecure directory settings for the portage dir. This spec
# also calls out to ruby which won't work with different ruby
# implementations.
sed -i -e '/can work in SAFE mode/,/^ end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
}

each_ruby_prepare() {
# Make sure the right ruby interpreter is used
sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
}

0 comments on commit 14ec128

Please sign in to comment.