Skip to content

Commit

Permalink
dev-embedded/rpi-eeprom: bump to 11.0_p1
Browse files Browse the repository at this point in the history
Nothing has changed in the "critical" default release channel, but "stable"
now has support for CM4/PI400.

News since 10.3_p1:
** 2020-12-14 - Promote pieeprom-2020-12-11.bin to stable - STABLE
   * Feature freeze to support stable release of BCM2711 XHCI boot, tryboot,
     HDMI_DELAY, USB MSD improvements.

** 2020-12-11 - CM4/PI400 conditional filters - BETA
   * Add support for [cm4] and [pi400] config conditionals filters.
   * Tidyup RPIBOOT USB descriptors.
   * Add a gap before displaying LED error pattern and change the default state
     to off after displaying the first error pattern.
   * Generate 0xffff instead of 0x0 if the checksum of the UDP packet to be
     transmitted is 0x0.
   * Rename USB-DEV to RPIBOOT in boot-mode strings. Bootmode was renamed to
     avoid confusion with USB MSD boot.

Closes: https://bugs.gentoo.org/760336
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Signed-off-by: Peter Alfredsen <[email protected]>
Closes: gentoo#18681
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
crabbedhaloablution authored and thesamesam committed Dec 17, 2020
1 parent 7bff7b3 commit 155785b
Show file tree
Hide file tree
Showing 2 changed files with 95 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-embedded/rpi-eeprom/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,5 @@ DIST rpi-eeprom_10.2-1.debian.tar.xz 7360 BLAKE2B e7959c4de4f3675632f0897b6f8abc
DIST rpi-eeprom_10.2.orig.tar.gz 7415652 BLAKE2B b1f56263c0037b2ba3bac2aecd9b5736736cf599bc68a743c065c853a20f56f18984816fdfb402bb499c3aa911dbe72376cec4647d87406cce2f4328b04cc2b1 SHA512 ea76a157ed57984fb0667e9171e3fbf7dba180e014faa9352b0c1904531dca9528b0e3204645a4af2b550670a52354b6b1be6af27e190d4523d8044f3349aa73
DIST rpi-eeprom_10.3-1.debian.tar.xz 10188 BLAKE2B 284a5465f2b5bc28c95135b8869218e83cbea9d0667b165de954f5c73549dfc190ddc838d956eec4c569c579e95ffc157054c6ed4bbd45e8ae88f786675cb164 SHA512 ead6b6c51d03493479c242e757edfc33bfdba4627f7501d90d0a181e8adc68f1503e0dac900b9b253a7286523f84d0e9afd8460d72f30b3ee8ee75b2f76811ab
DIST rpi-eeprom_10.3.orig.tar.gz 7635402 BLAKE2B 3153eda08eada4c9e4f05d7a68ac4661413591314c4980e16ee876d49e756e2e13a101765b579adbe51e0e3b88cdfe419b71a58da858250781e0f292220dc397 SHA512 ea5a6ae47be5052b4793161d891a1e3a72dda951c95f15797d7baf68d475fcec1250638e4c43a32578ceef10563ebce052e746bc8fc60f8cf8d90780d5a7e8a7
DIST rpi-eeprom_11.0-1.debian.tar.xz 10248 BLAKE2B a83230dc13ce296963ed206725d465a69536f5cd23f52076fda2601ceea06354f365e1f8b2d9a93a4396826b5e9d9ab5ad40fd6336116e693419fd3b4630b5e1 SHA512 939fa16fbd8c21340ca77cc74f3cee22772d25cd6dcb70c178d70c1762ae9b9acb9e7a070b2c3a7f114841712142284c1f2bdb23fb528a229507d8eae6477c84
DIST rpi-eeprom_11.0.orig.tar.gz 8075596 BLAKE2B ccbd895de728566bfb0402c2378f6eb13f88948490e14f1e251f6440f3ef31879ea66c0fe94761e1abf40a23924742e8c2f33c49200e710542131091b223b292 SHA512 0ea2971b752a53a4529b2c3d3b814b9e743440397f8c4d21c9a06493561a37bc8cd8c0adaaab389f41b1697584d12641f49d7a93d6541f9dda3bba5d6dd1371c
93 changes: 93 additions & 0 deletions dev-embedded/rpi-eeprom/rpi-eeprom-11.0_p1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8,9} )

inherit python-r1 systemd

DESCRIPTION="Updater for Raspberry Pi 4 bootloader and the VL805 USB controller"
HOMEPAGE="https://github.com/raspberrypi/rpi-eeprom/"
MY_P="${PN}-$(ver_cut 1-2)"
MY_BASE_URL="https://archive.raspberrypi.org/debian/pool/main/r/${PN}/${PN}_$(ver_cut 1-2)"
SRC_URI="${MY_BASE_URL}-$(ver_cut 4).debian.tar.xz
${MY_BASE_URL}.orig.tar.gz"
S="${WORKDIR}"

SLOT="0"
LICENSE="BSD rpi-eeprom"
KEYWORDS="~arm ~arm64"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

BDEPEND="sys-apps/help2man"
DEPEND="${PYTHON_DEPS}"
RDEPEND="${PYTHON_DEPS}
sys-apps/flashrom
|| (
>=media-libs/raspberrypi-userland-0_pre20201022
>=media-libs/raspberrypi-userland-bin-1.20201022
)"

src_prepare() {
default
sed -i \
-e 's:/etc/default/rpi-eeprom-update:/etc/conf.d/rpi-eeprom-update:' \
"${MY_P}/rpi-eeprom-update" || die "Failed sed on rpi-eeprom-update"
sed -i \
-e 's:/usr/bin/rpi-eeprom-update:/usr/sbin/rpi-eeprom-update:' \
"debian/rpi-eeprom.rpi-eeprom-update.service" || die "Failed sed on rpi-eeprom.rpi-eeprom-update.service"
}

src_install() {
pushd "${MY_P}" 1>/dev/null || die "Cannot change into directory ${MY_P}"

python_scriptinto /usr/sbin
python_foreach_impl python_newscript rpi-eeprom-config rpi-eeprom-config

dosbin rpi-eeprom-update
keepdir /var/lib/raspberrypi/bootloader/backup

for dir in critical stable beta; do
insinto /lib/firmware/raspberrypi/bootloader
doins -r firmware/${dir}
done

dodoc firmware/release-notes.md

help2man -N \
--version-string="${PV}" --help-option="-h" \
--name="Bootloader EEPROM configuration tool for the Raspberry Pi 4B" \
--output=rpi-eeprom-config.1 ./rpi-eeprom-config || die "Failed to create manpage for rpi-eeprom-config"

help2man -N \
--version-string="${PV}" --help-option="-h" \
--name="Checks whether the Raspberry Pi bootloader EEPROM is \
up-to-date and updates the EEPROM" \
--output=rpi-eeprom-update.1 ./rpi-eeprom-update || die "Failed to create manpage for rpi-eeprom-update"

doman rpi-eeprom-update.1 rpi-eeprom-config.1

newconfd rpi-eeprom-update-default rpi-eeprom-update

popd 1>/dev/null || die

pushd debian 1>/dev/null || die "Cannot change into directory debian"

systemd_newunit rpi-eeprom.rpi-eeprom-update.service rpi-eeprom-update.service
newdoc changelog changelog.Debian

popd 1>/dev/null || die

newinitd "${FILESDIR}/init.d_rpi-eeprom-update-1" "rpi-eeprom-update"
}

pkg_postinst() {
elog 'To have rpi-eeprom-update run at each startup, enable and start either'
elog '/etc/init.d/rpi-eeprom-update (for openrc users)'
elog 'or'
elog 'rpi-eeprom-update.service (for systemd users)'
elog '/etc/conf.d/rpi-eeprom-update contains the configuration.'
elog 'FIRMWARE_RELEASE_STATUS="critical|stable|beta" determines'
elog 'which release track you get. "critical" is recommended and the default.'
}

0 comments on commit 155785b

Please sign in to comment.