Skip to content

Commit

Permalink
dev-db/freetds: bump to EAPI 6, add maintainer-needed
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
austin987 committed Jul 7, 2016
1 parent 8bc1350 commit 155c3ee
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
49 changes: 49 additions & 0 deletions dev-db/freetds/freetds-1.00.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools eutils

DESCRIPTION="Tabular Datastream Library"
HOMEPAGE="http://www.freetds.org/"
SRC_URI="ftp://ftp.freetds.org/pub/freetds/stable/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos"
IUSE="kerberos odbc iodbc mssql"
RESTRICT="test"

DEPEND="
iodbc? ( dev-db/libiodbc )
kerberos? ( virtual/krb5 )
odbc? ( dev-db/unixODBC )"
RDEPEND="${DEPEND}"

src_prepare() {
default
config_rpath_update
sed -ie 's:with_iodbc/include":with_iodbc/include/iodbc":' configure.ac || die
eautoreconf
}

src_configure() {
local myconf="--with-tdsver=7.0 $(use_enable mssql msdblib)"

if use iodbc ; then
myconf="${myconf} --enable-odbc --with-iodbc=${EPREFIX}/usr"
elif use odbc ; then
myconf="${myconf} --enable-odbc --with-unixodbc=${EPREFIX}/usr"
fi
if use kerberos ; then
myconf="${myconf} --enable-krb5"
fi

econf ${myconf}
}

src_install() {
emake DESTDIR="${D}" DOCDIR="doc/${PF}" install
}
1 change: 1 addition & 0 deletions dev-db/freetds/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
</pkgmetadata>

0 comments on commit 155c3ee

Please sign in to comment.