Skip to content

Commit

Permalink
dev-util/android-studio: bump to 2.1.3
Browse files Browse the repository at this point in the history
Also, drop 32bit deps, the latest sdk tools are 64bit finally.

Gentoo-Bug: https://bugs.gentoo.org/589556

Package-Manager: portage-2.2.28
  • Loading branch information
perfinion committed Aug 29, 2016
1 parent 425cad5 commit 17627f8
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/android-studio/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST android-studio-ide-143.2915827-linux.zip 305181285 SHA256 baaa0555c96b542d047bce3b03ff41e38f422bed9e1a7f1e55fb1c4b3daac160 SHA512 42f0e6ebd51fc92f64f3bcfa980df3853922e6bff043ae23fbd7564b79cb905b30927bbee534613a52a92d24e60bad89ee577a06e382b301d5f7f773c166ce07 WHIRLPOOL a344331a3b308b2497e68ac5e13f4d1ef224c02e44d2fcf6cd48f0981bd25a4c87c9355f014fda23a5241e76719a5a6f79ed2424387c70fffc7c4cf964e526b9
DIST android-studio-ide-143.3101438-linux.zip 286664165 SHA256 722f944124c395d0c82565257d23441ebc77775f7fae47099f8cd48c571c9ff6 SHA512 3890dcec1c773732a4b54e6e6dd90f9f9b63c396fb0d2712fa4a5b2b8487a055e910f983a8c4da8e3e5b103021267415eb6065f291bd35a633c4723e5cb648cb WHIRLPOOL f81dbb0c9e4f7a4ac6ff93dbf75022ac9d557503fd89901a24dc9afdf2850cb23c931c52a01101e7fbe87cb5e076f998823a2d7b7e2103d682fdbe7c2b9755b9
62 changes: 62 additions & 0 deletions dev-util/android-studio/android-studio-2.1.3.0.143.3101438.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils versionator

RESTRICT="strip"
QA_PREBUILT="opt/${PN}/bin/libbreakgen*.so opt/${PN}/bin/fsnotifier*"
if [[ $(get_version_component_count) -eq 6 ]]; then
STUDIO_V=$(get_version_component_range 1-4)
BUILD_V=$(get_version_component_range 5-6)
else
STUDIO_V=$(get_version_component_range 1-3)
BUILD_V=$(get_version_component_range 4-5)
fi

DESCRIPTION="A new Android development environment based on IntelliJ IDEA"
HOMEPAGE="http://developer.android.com/sdk/installing/studio.html"
SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="selinux"
KEYWORDS="~amd64 ~x86"

DEPEND="app-arch/zip"
RDEPEND=">=virtual/jdk-1.7
selinux? ( sec-policy/selinux-android )
>=app-arch/bzip2-1.0.6-r4
>=dev-libs/expat-2.1.0-r3
>=dev-libs/libffi-3.0.13-r1
>=media-libs/fontconfig-2.10.92
>=media-libs/freetype-2.5.5
>=media-libs/libpng-1.2.51
>=media-libs/mesa-10.2.8
|| ( >=sys-libs/ncurses-5.9-r3:5/5 >=sys-libs/ncurses-5.9-r3:0/5 )
>=sys-libs/zlib-1.2.8-r1
>=x11-libs/libX11-1.6.2
>=x11-libs/libXau-1.0.7-r1
>=x11-libs/libXdamage-1.1.4-r1
>=x11-libs/libXdmcp-1.1.1-r1
>=x11-libs/libXext-1.3.2
>=x11-libs/libXfixes-5.0.1
>=x11-libs/libXrender-0.9.8
>=x11-libs/libXxf86vm-1.1.3
>=x11-libs/libdrm-2.4.46
>=x11-libs/libxcb-1.9.1
>=x11-libs/libxshmfence-1.1"
S=${WORKDIR}/${PN}

src_install() {
local dir="/opt/${PN}"

insinto "${dir}"
doins -r *
fperms 755 "${dir}/bin/studio.sh" "${dir}/bin/fsnotifier" "${dir}/bin/fsnotifier64"

newicon "bin/studio.png" "${PN}.png"
make_wrapper ${PN} ${dir}/bin/studio.sh
make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE"
}

0 comments on commit 17627f8

Please sign in to comment.