Skip to content

Commit

Permalink
app-emulation/dosemu: backported glibc detection, bug #597880
Browse files Browse the repository at this point in the history
Reported-by: [email protected]
Bug: https://bugs.gentoo.org/597880

Package-Manager: portage-2.3.2
  • Loading branch information
Sergei Trofimovich committed Oct 29, 2016
1 parent 4eeb397 commit 1782ca0
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 1 deletion.
5 changes: 4 additions & 1 deletion app-emulation/dosemu/dosemu-1.4.1_pre20091009.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

inherit eutils flag-o-matic
inherit autotools eutils flag-o-matic

P_FD="dosemu-freedos-1.0-bin"
DESCRIPTION="DOS Emulator"
Expand Down Expand Up @@ -36,6 +36,9 @@ S="${WORKDIR}/${PN}"
src_compile() {
epatch "${FILESDIR}"/${P}-flex.patch #437074
epatch "${FILESDIR}"/${P}-dash.patch
epatch "${FILESDIR}"/${P}-fix-glibc.patch #597880

eautoreconf

# Has problems with -O3 on some systems
replace-flags -O[3-9] -O2
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
The patch is a subset of

commit b028d3fd33b004ac61583927884a64577e2d64c3
Author: Bart Oldeman <[email protected]>
Date: Sun Dec 23 22:08:11 2012 -0500

to fix glibc detection for
Bug: https://bugs.gentoo.org/597880
diff --git a/configure.ac b/configure.ac
index 70bc154..b8da5e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -644,19 +640,9 @@ if test "$GCC" = "yes" ; then
fi

AC_MSG_CHECKING(for glibc...)
- set `printf '%b\n' '#include <features.h>\nXXAaZZ __GLIBC__ XXBbZZ __GLIBC_MINOR__'|${CC-cc} -E -|awk '/XXAaZZ/ {print $2 " " $4}'`
- major=$1; minor=$2
- if test "$major" = "__GLIBC__"; then
- AC_MSG_ERROR([Sorry, you need glibc-2.1.3 or newer.])
- else
- if test "$minor" = "__GLIBC_MINOR__"; then
- minor=0;
- fi
- GLIBC_VERSION_CODE=$((($major * 1000) + $minor))
- AC_MSG_RESULT([yes, version code $GLIBC_VERSION_CODE])
- if test $GLIBC_VERSION_CODE -lt 2001; then
- AC_MSG_ERROR([Sorry, you need glibc-2.1.3 or newer.])
- fi
+ set `printf '%b\n' '#include <features.h>\nXXAaZZ __GLIBC__'|${CC-cc} -E -|awk '/XXAaZZ/ {print $2}'`
+ if test "$1" = "__GLIBC__"; then
+ AC_MSG_ERROR([Sorry, you need glibc.])
fi
fi

0 comments on commit 1782ca0

Please sign in to comment.