Skip to content

Commit

Permalink
app-arch/zstd: Bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Signed-off-by: Patrick Lauer <[email protected]>
  • Loading branch information
patricklauer committed Dec 17, 2020
1 parent d023037 commit 17b1735
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/zstd/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST zstd-1.4.4.tar.gz 1962617 BLAKE2B e21841a53b6c60703e5500cfc2a02923c4c3e57975aa57e1060310171e0d83d7c8eda1bd0510d5736db5c310d76847d2105ac5f614867fc3a9dc3086a035dfd7 SHA512 8209837e8eb14e474dfe21d5511085f46cef93b03ab77613fd41e7b8be652418231c38852669c8e0b55b78ad41ea2cb8008d0da122a83f8f27e32b5c86f045cf
DIST zstd-1.4.5.tar.gz 1987927 BLAKE2B 1497d4e87040e5c71466468ebf1a57f4073666f2b005229925bc1d95a4b4fcb2a51d88bb79be20f21860e5750da42f8aac21d2997421d07ba37bd6bb12a28b55 SHA512 b03c497c3e0590c3d384cb856e3024f144b2bfac0d805d80e68deafa612c68237f12a2d657416d476a28059e80936c79f099fc42331464b417593895ea214387
DIST zstd-1.4.7.tar.gz 1817193 BLAKE2B 8a307fa7efca8baa45c61eb0e46c5b6eedff1459a9493d81ad7033b9050ccf96e39cfc0f5b913ea20fb64d5efa26063b70e36e6cc47077b17106f3b5135fd999 SHA512 720941fc484e36e2f2bd74f120966fc598781a7abb945ed2f553d4cb035fa007117d00b72979b037817fbaff60b0d72f698fc16561ccbd46b16ae2888b044548
73 changes: 73 additions & 0 deletions app-arch/zstd/zstd-1.4.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic multilib-minimal toolchain-funcs

DESCRIPTION="zstd fast compression library"
HOMEPAGE="https://facebook.github.io/zstd/"
SRC_URI="https://github.com/facebook/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="|| ( BSD GPL-2 )"
SLOT="0/1"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="lz4 static-libs +threads"

RDEPEND="app-arch/xz-utils
lz4? ( app-arch/lz4 )"
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}/${PN}-1.4.5-fix-uclibc-ng.patch" #741972
)

src_prepare() {
default
multilib_copy_sources

# Workaround #713940 / https://github.com/facebook/zstd/issues/2045
# where upstream build system does not add -pthread for Makefile-based
# build system.
use threads && append-flags $(test-flags-CCLD -pthread)
}

mymake() {
emake \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \
AR="$(tc-getAR)" \
PREFIX="${EPREFIX}/usr" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
"${@}"
}

multilib_src_compile() {
local libzstd_targets=( libzstd{,.a}$(usex threads '-mt' '') )

mymake -C lib ${libzstd_targets[@]} libzstd.pc

if multilib_is_native_abi ; then
mymake HAVE_LZ4="$(usex lz4 1 0)" zstd

mymake -C contrib/pzstd
fi
}

multilib_src_install() {
mymake -C lib DESTDIR="${D}" install

if multilib_is_native_abi ; then
mymake -C programs DESTDIR="${D}" install

mymake -C contrib/pzstd DESTDIR="${D}" install
fi
}

multilib_src_install_all() {
einstalldocs

if ! use static-libs; then
find "${ED}" -name "*.a" -delete || die
fi
}

0 comments on commit 17b1735

Please sign in to comment.