Skip to content

Commit

Permalink
dev-libs/libcoyotl: port to EAPI 7
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 20, 2021
1 parent ec5cfb0 commit 18414ad
Show file tree
Hide file tree
Showing 3 changed files with 25 additions and 21 deletions.
10 changes: 4 additions & 6 deletions dev-libs/libcoyotl/files/3.1.0-gcc-4.3.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
diff -NrU5 libcoyotl-3.1.0.orig/libcoyotl/command_line.cpp libcoyotl-3.1.0/libcoyotl/command_line.cpp
--- libcoyotl-3.1.0.orig/libcoyotl/command_line.cpp 2008-03-21 22:41:41.000000000 +0100
+++ libcoyotl-3.1.0/libcoyotl/command_line.cpp 2008-03-21 22:41:59.000000000 +0100
--- a/libcoyotl/command_line.cpp
+++ b/libcoyotl/command_line.cpp
@@ -30,10 +30,13 @@
// http://www.coyotegulch.com
//
Expand All @@ -15,9 +14,8 @@ diff -NrU5 libcoyotl-3.1.0.orig/libcoyotl/command_line.cpp libcoyotl-3.1.0/libco
command_line::command_line(int argc, char * argv[], const set<string> & bool_opts)
: m_options(),
m_inputs(),
diff -NrU5 libcoyotl-3.1.0.orig/libcoyotl/sortutil.h libcoyotl-3.1.0/libcoyotl/sortutil.h
--- libcoyotl-3.1.0.orig/libcoyotl/sortutil.h 2008-03-21 22:41:41.000000000 +0100
+++ libcoyotl-3.1.0/libcoyotl/sortutil.h 2008-03-21 22:41:59.000000000 +0100
--- a/libcoyotl/sortutil.h
+++ b/libcoyotl/sortutil.h
@@ -34,10 +34,11 @@
//-----------------------------------------------------------------------

Expand Down
4 changes: 2 additions & 2 deletions dev-libs/libcoyotl/files/3.1.0-gcc-4.7.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- libcoyotl/maze_renderer.cpp.ORIG 2005-10-10 06:48:30.000000000 +0200
+++ libcoyotl/maze_renderer.cpp 2013-04-12 10:29:31.127689828 +0200
--- a/libcoyotl/maze_renderer.cpp
+++ b/libcoyotl/maze_renderer.cpp
@@ -36,6 +36,8 @@
#include "maze_renderer.h"
using namespace libcoyotl;
Expand Down
32 changes: 19 additions & 13 deletions dev-libs/libcoyotl/libcoyotl-3.1.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
EAPI=7

inherit autotools epatch ltprune
inherit autotools

DESCRIPTION="A collection of portable C++ classes"
HOMEPAGE="http://www.coyotegulch.com/products/libcoyotl/"
Expand All @@ -12,39 +12,45 @@ SRC_URI="http://www.coyotegulch.com/distfiles/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"

IUSE="doc static-libs"
IUSE="doc"

RDEPEND="media-libs/libpng:0="
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
DEPEND="${RDEPEND}"
BDEPEND="doc? ( app-doc/doxygen )"

DOCS=( AUTHORS ChangeLog NEWS README )

PATCHES=(
"${FILESDIR}"/${PV}-gcc-4.3.patch
"${FILESDIR}"/${PV}-gcc-4.7.patch
)

src_prepare() {
epatch "${FILESDIR}/${PV}-gcc-4.3.patch"
epatch "${FILESDIR}/${PV}-gcc-4.7.patch"
epatch_user
default

eautoreconf
}

src_configure() {
ac_cv_prog_HAVE_DOXYGEN="false" econf $(use_enable static-libs static)
ac_cv_prog_HAVE_DOXYGEN="false" econf --disable-static
}

src_compile() {
emake

if use doc ; then
cd docs
cd docs || die
doxygen libcoyotl.doxygen || die "generating docs failed"
fi
}

src_install() {
default
prune_libtool_files

find "${ED}" -name '*.la' -delete || die

if use doc ; then
dohtml docs/html/*
docinto html
dodoc docs/html/*
fi
}

0 comments on commit 18414ad

Please sign in to comment.