Skip to content

Commit

Permalink
app-arch/torrentzip: Fix SRC_URI. Bump to EAPI 6. Bump to version 0.9
Browse files Browse the repository at this point in the history
Also assign package to Alexander Miller <[email protected]>.

Gentoo-Bug: https://bugs.gentoo.org/575338

Package-Manager: portage-2.2.26
  • Loading branch information
monsieurp committed Mar 22, 2016
1 parent d44e7b5 commit 18442b4
Show file tree
Hide file tree
Showing 6 changed files with 59 additions and 49 deletions.
4 changes: 2 additions & 2 deletions app-arch/torrentzip/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
DIST torrentzip-0.2.tar.gz 46971 SHA256 9e55f378ef5c75c452b3f52728a7503ca76e147e0ab2395b8c41de8c20995efd SHA512 802dd1bf55e0a31df75d8195c9d2d5610be8cb7f14d14278eba72b580aff3ad415711999db05a5425303380ebfc82a68896e276319e0ead5635d0a07615ba700 WHIRLPOOL 79c96f51a0b547b2651625a3b3aee6b7a769955e10b092654086a1d91a494d08f8dd732eee45b432ca97f4f6314af0f76907fa81b422ef94676e6d729994a61d
DIST torrentzip-0.2.zip 69200 SHA256 3aa58e839743eebd97071e36585bb14cab0bddd22db646eb0765e1ae3ef2c749 SHA512 a6d6452940ab9070b96d598c7db306657afa34c3630160943260e6687e65985aa5aa8ad0b1319ee6470912207d6ef369fdb1168d5d528e8efd7405dc7722b1b8 WHIRLPOOL 0cad9f83e2d27795014be51b912d34350a59ad9c824f66237e1f15641daad812c92a7d5c6357e8d6a2517f08a381705f4eb057dc855700b007b99f3210046a1c
DIST torrentzip-0.9.tar.gz 59007 SHA256 89059002613e3e9f06861ae90047e3d4ea6cc1b2cc4ef21bd75cb51cecb2bff6 SHA512 691cd25f501de3de16b5b15b2afadfc34b833c3e93208c2c3497674936580ad2c3532a02e02531b89974302eee7b36f7579a412718914b1b38044b78a39a4d4d WHIRLPOOL 0e172c0797d2577afd632d9d53d09a2cb25d05e78037984963996999a719aaf7295dc264554794f0b1f2eba8bb162c2ecc9d584a058c241b6f84849c0ab47e7b
DIST trrntzip_v02_src.tar.gz 46971 SHA256 9e55f378ef5c75c452b3f52728a7503ca76e147e0ab2395b8c41de8c20995efd SHA512 802dd1bf55e0a31df75d8195c9d2d5610be8cb7f14d14278eba72b580aff3ad415711999db05a5425303380ebfc82a68896e276319e0ead5635d0a07615ba700 WHIRLPOOL 79c96f51a0b547b2651625a3b3aee6b7a769955e10b092654086a1d91a494d08f8dd732eee45b432ca97f4f6314af0f76907fa81b422ef94676e6d729994a61d
11 changes: 11 additions & 0 deletions app-arch/torrentzip/files/torrentzip-0.2-fix-perms.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/src/trrntzip.c
+++ b/src/trrntzip.c
@@ -782,7 +782,7 @@

if (strstr (szTmpBuf, ".zip\0") && !(istat.st_mode & S_IWUSR))
{
- chmod (direntp->d_name, S_IWUSR);
+ chmod (direntp->d_name, S_IWUSR | S_IRUSR);
mig.cEncounteredZips++;

if (!mig.fProcessLog)
11 changes: 10 additions & 1 deletion app-arch/torrentzip/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,7 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<maintainer type="person">
<email>[email protected]</email>
<name>Alexander Miller</name>
<description>Proxied maintainer</description>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>

<longdescription>
TorrentZip is a replacement for MameZip. The goal of the program is to
use standard values when creating zips to create identical files over
Expand Down
42 changes: 0 additions & 42 deletions app-arch/torrentzip/torrentzip-0.2-r2.ebuild

This file was deleted.

Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
EAPI="6"

inherit eutils autotools

Expand All @@ -12,7 +12,7 @@ HOMEPAGE="https://sourceforge.net/projects/trrntzip"
MY_PN="trrntzip"
MY_P="${MY_PN}_v${PV/.}"

SRC_URI="mirror://sourceforge/trrntzip/${MY_P}_src.tar.gz -> ${P}.tar.gz"
SRC_URI="mirror://sourceforge/trrntzip/${MY_P}_src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
Expand All @@ -22,11 +22,12 @@ RDEPEND="$DEPEND"

S="${WORKDIR}/${MY_PN}"
DOCS=(README AUTHORS)
PATCHES=("${FILESDIR}/${P}-fix-perms.patch")

src_prepare() {
export CPPFLAGS+=" -DOF\\(args\\)=args"
default

epatch_user
export CPPFLAGS+=" -DOF\\(args\\)=args"

eautoreconf
}
31 changes: 31 additions & 0 deletions app-arch/torrentzip/torrentzip-0.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools

DESCRIPTION="Create identical zip archives over multiple systems"
HOMEPAGE="https://sourceforge.net/projects/trrntzip"
SRC_URI="http://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="
sys-libs/zlib"

DEPEND="
${RDEPEND}
app-arch/unzip"

DOCS=(README AUTHORS)

src_prepare() {
default
export CPPFLAGS+=" -DOF\\(args\\)=args"
eautoreconf
}

0 comments on commit 18442b4

Please sign in to comment.