Skip to content

Commit

Permalink
sci-libs/libsigrokdecode: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.0, Repoman-2.3.1
  • Loading branch information
swegener committed Dec 30, 2016
1 parent 5ba732c commit 188d943
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-libs/libsigrokdecode/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libsigrokdecode-0.3.0.tar.gz 607691 SHA256 ee4ebb1df99fbd1df40234d08a6c7f3e10393f087de627197347e2268ad6478f SHA512 d943091bdb1b20b11191f7a93ec8a305ba702e732247d7fbfd61fd9ae9fc4d61556bdec987c07bed11ddc20d3ab85ff8118ddc75161ebd9d9d1abe8cfc48ac19 WHIRLPOOL 4785173ff85fe62bdc4a0c2f0f8e58fb3da6d6512164c30fb3e6edbb0c2318de49a0b64bb92570549b6975279bdea0659b810c191a39dd50be0583c618f941d8
DIST libsigrokdecode-0.4.0.tar.gz 694223 SHA256 fd7e9d1b73245e844ead97a16d5321c766196f946c9b28a8646cab2e98ec3537 SHA512 54e8a3defb5f8b0cfc354e42a8c997d7515b70f40f0c069adf9ec0cc022835c5e77708e33588099878b5793f6a9acbb7e438f807ce6dabcaeca2fa17d208009b WHIRLPOOL b8cb9c41d66842270a8cbc27d25d7234696380bc6eda3c2327ea7d4761e6e5ba5074714d89c23c3a5ffbaa06a5261a89a61bf6c5dc98100772b924738b4c0148
DIST libsigrokdecode-0.4.1.tar.gz 751546 SHA256 065f70c10971173d86e03a8cf5534e600c7a622775113997d8061572135d4a95 SHA512 b072001190e80a194986524fd4de4d32f4559d618b151a3dbfa2c63b292c8a490535cb7479cfa665c4e8d3798251a5d6f5ecfa456ca669237237ffced3e88272 WHIRLPOOL c06a46a593120f474f5b102bd51add7153176fb596cf8f2cb361028ea6e1f6abd1bd4ba989ce812707989c46010eab8e6c211bd50156922ebf1bbbb04c7021bf
55 changes: 55 additions & 0 deletions sci-libs/libsigrokdecode/libsigrokdecode-0.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"

PYTHON_COMPAT=( python3_4 )

inherit eutils python-single-r1

if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
inherit git-r3 autotools
else
SRC_URI="http://sigrok.org/download/source/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="provide (streaming) protocol decoding functionality"
HOMEPAGE="http://sigrok.org/wiki/Libsigrokdecode"

LICENSE="GPL-3"
SLOT="0"
IUSE="static-libs"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND=">=dev-libs/glib-2.24.0
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
virtual/pkgconfig"

src_prepare() {
[[ ${PV} == "9999" ]] && eautoreconf

# Only a test program (not installed, and not used by src_test)
# is used by libsigrok, so disable it to avoid the compile.
sed -i \
-e '/build_runtc=/s:yes:no:' \
configure || die

eapply_user
}

src_configure() {
econf $(use_enable static-libs static)
}

src_test() {
emake check
}

src_install() {
default
prune_libtool_files
}

0 comments on commit 188d943

Please sign in to comment.