Skip to content

Commit

Permalink
app-misc/cmatrix: EAPI 6 bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
monsieurp committed May 31, 2016
1 parent db9dd6b commit 18a2e54
Showing 1 changed file with 46 additions and 0 deletions.
46 changes: 46 additions & 0 deletions app-misc/cmatrix/cmatrix-1.2a-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6

inherit autotools eutils

DESCRIPTION="An ncurses based app to show a scrolling screen from the Matrix"
HOMEPAGE="http://www.asty.org/cmatrix"
SRC_URI="http://www.asty.org/${PN}/dist/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="X"

DEPEND="
X? ( x11-apps/mkfontdir )
sys-libs/ncurses:0="

RDEPEND="${DEPEND}"

CPATCHES=( "${FILESDIR}"/${P}-gentoo.patch )

src_prepare() {
default
use X && CPATCHES+=( "${FILESDIR}"/${P}-fontdir.patch )
epatch "${CPATCHES[@]}"
eautoreconf
}

src_install() {
dodir /usr/share/consolefonts
dodir /usr/lib/kbd/consolefonts
use X && dodir /usr/share/fonts/misc
emake DESTDIR="${D}" install
}

pkg_postinst() {
if use X; then
if [[ -d "${ROOT}"usr/share/fonts/misc ]] ; then
einfo ">>> Running mkfontdir on ${ROOT}usr/share/fonts/misc"
mkfontdir "${ROOT}"usr/share/fonts/misc || die 'mkfontdir failed'
fi
fi
}

0 comments on commit 18a2e54

Please sign in to comment.