Skip to content

Commit

Permalink
dev-python/webencodings: New package, ebuild written by me
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Jan 15, 2016
1 parent f842bea commit 18aee7e
Show file tree
Hide file tree
Showing 3 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/webencodings/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST webencodings-0.4.tar.gz 9412 SHA256 3a45b2af274dabbb84eb68256bf0fb1e2e87a48ae4ad3ba4d7936cef3ce14e1d SHA512 3f46e26dd555838397a52e74304452b39fbe05032b4fed4a4f2574580bd71eac50c242aacd7ebc23ecb860d4ea6e0690b7a7ea4cc974382a4a1303a36f8ffd46 WHIRLPOOL 623c83aa106ae251100d995c632f1ddcb5b4b46fd1bc03b7565c69ad6f5f918d81039ccc7bd8048beef1e87a4aed643bfe4f045839b12ad00f0e232933b57a2c
13 changes: 13 additions & 0 deletions dev-python/webencodings/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
<upstream>
<remote-id type="pypi">webencodings</remote-id>
<doc>http://pythonhosted.org/webencodings/</doc>
<maintainer status="unknown">
<email>[email protected]</email>
<name>Simon Sapin</name>
</maintainer>
</upstream>
</pkgmetadata>
36 changes: 36 additions & 0 deletions dev-python/webencodings/webencodings-0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="Character encoding aliases for legacy web content"
HOMEPAGE="https://github.com/SimonSapin/python-webencodings http://pypi.python.org/pypi/webencodings"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"

RDEPEND=""
DEPEND="${REDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"

# https://github.com/SimonSapin/python-webencodings/issues/2
RESTRICT=test

python_test() {
cat >> setup.cfg <<- EOF
[pytest]
python_files=test*.py
EOF
py.test -v -v || die
}

0 comments on commit 18aee7e

Please sign in to comment.