Skip to content

Commit

Permalink
x11-misc/habak: Update HOMEPAGE/SRC_URI
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Fixes: https://bugs.gentoo.org/700712
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Nov 20, 2019
1 parent 5fc1b4f commit 18c8587
Show file tree
Hide file tree
Showing 3 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-misc/habak/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST habak-0.2.5-sourceforge.tar.gz 28747 BLAKE2B 60c6f60e0a16dca2091f41c9e4f419e5fb4be88a3ce44de98d91740f94e468fb7bd64bbf0b399b64035c21547b50fccf2e40954e0ff59ab1f1c0ce8dc6e56670 SHA512 4b1ff1484c65f74441b297e558360a8f2ea8f12ac63c4b74f846e41328dd84a1d619bde55e81224c3bd527897625e17bc07a6bb0d4cc3bd0eec6f4e787201277
DIST habak-0.2.5.tar.bz2 22657 BLAKE2B 10b3c4808251b255bcf26935974514a2df5946520bd4bc080b9bdc551c727925c8b9a7485124013303654769b9daacff42d54fc0e5d567b26d99c5a75a0a50c2 SHA512 256ac24a3b322397b6cdbd2ca8add5938c77d166092a783234baa6186c3b4e01aeffd0b890749c7ac14aa39961e5fc6326f614ceb04eadfc5e4af282d04b7188
30 changes: 30 additions & 0 deletions x11-misc/habak/files/habak-0.2.5-gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
--- a/src/Makefile
--- b/src/Makefile
@@ -2,22 +2,22 @@
#LDFLAGS = -L/usr/X11R6/lib -lImlib2 -lm -g -ggdb

CFLAGS += -I/usr/X11R6/include -Wall
-LDFLAGS += -L/usr/X11R6/lib -lImlib2 -lm
+LIBS = -lm $(shell $(PKG_CONFIG) --libs imlib2 x11)

all: habak
ln -f habak ../habak

habak: xcore.o random.o habak.o
- gcc $(LDFLAGS) -o habak xcore.o random.o habak.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -o habak xcore.o random.o habak.o $(LIBS)

habak.o: habak.c types.h defaults.h proto.h
- gcc $(CFLAGS) -c habak.c -o habak.o
+ $(CC) $(CFLAGS) -c habak.c -o habak.o

random.o: random.c proto.h
- gcc $(CFLAGS) -c random.c -o random.o
+ $(CC) $(CFLAGS) -c random.c -o random.o

xcore.o: xcore.c
- gcc $(CFLAGS) -c xcore.c -o xcore.o
+ $(CC) $(CFLAGS) -c xcore.c -o xcore.o

clean:
rm habak *.o
37 changes: 37 additions & 0 deletions x11-misc/habak/habak-0.2.5-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit toolchain-funcs

DESCRIPTION="A simple but powerful tool to set desktop wallpaper"
HOMEPAGE="https://sourceforge.net/projects/fvwm-crystal/"
SRC_URI="https://sourceforge.net/projects/fvwm-crystal/files/${PN}/${PV}/${P}.tar.gz/download -> ${P}-sourceforge.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"

RDEPEND="
media-libs/imlib2[X]
x11-libs/libX11
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
x11-base/xorg-proto
"
DOCS=( ChangeLog README TODO "${FILESDIR}"/README.en )
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
)

src_compile() {
tc-export CC PKG_CONFIG
emake -C src ${PN}
}

src_install() {
dobin src/${PN}
einstalldocs
}

0 comments on commit 18c8587

Please sign in to comment.