Skip to content

Commit

Permalink
app-backup/snapper: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
dlan17 committed Aug 25, 2016
1 parent 3945c4b commit 193c338
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-backup/snapper/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST snapper-0.2.8.tar.bz2 475053 SHA256 a44608648ed21a1346f8ae9345044901c39ad01abb501806a22c9d4a771eadc5 SHA512 ce1529062943c34b9de2eafb62c6e28b39bda6f4afc23ec5df5ddd42f213cbaf0d77d94d11d982285114ceecd27bd48206436119af84b2769ed4792aab01c75d WHIRLPOOL 3463cf8beb7adb1f3869645b20928dc21fc9cb72f8ed5275688e0b53c97b8103d0536e3246f12fcdc90c1889d221d13ce131b1920c7298232212c003ea9abb6d
DIST snapper-0.3.3.tar.bz2 545800 SHA256 e64f42417fffed65524ce125eb31b5dbdd802a519ef04dd88c9251ef2784fe10 SHA512 f24f6d121f9a613549899b7bf3751f6d9c101db716d7bc3858a2add9f90e08861fc46927ce0130efc232240a91e24934820d0c2b1b65f206ac80d04cdaaec39d WHIRLPOOL 8a55ec12330d13bb1c4a630584418eb0e4f64580324ec8ff9fe444a1d52a4eafddac6c6c6cefc8aec760d84336f24c389e3f6d79ff07d9a40bb69cedbf35c8b7
73 changes: 73 additions & 0 deletions app-backup/snapper/snapper-0.3.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils

DESCRIPTION="Command-line program for btrfs and ext4 snapshot management"
HOMEPAGE="http://snapper.io/"
SRC_URI="ftp://ftp.suse.com/pub/projects/snapper/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+btrfs ext4 lvm pam xattr"

RDEPEND="dev-libs/boost[threads]
dev-libs/libxml2
dev-libs/icu:=
sys-apps/acl
sys-apps/dbus
sys-apps/util-linux
sys-libs/zlib
virtual/libintl
btrfs? ( >=sys-fs/btrfs-progs-3.17.1 )
ext4? ( sys-fs/e2fsprogs )
lvm? ( sys-fs/lvm2 )
pam? ( sys-libs/pam )
xattr? ( sys-apps/attr )"

DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig"

REQUIRED_USE="|| ( btrfs ext4 lvm )"

DOCS=( AUTHORS )

src_prepare() {
epatch "${FILESDIR}"/cron-confd.patch
}

src_configure() {
local myeconfargs=(
--with-conf="/etc/conf.d"
--docdir="/usr/share/doc/${PF}"
--disable-zypp
--enable-rollback
$(use_enable btrfs)
$(use_enable ext4)
$(use_enable lvm)
$(use_enable pam)
$(use_enable xattr xattrs)
)

econf "${myeconfargs[@]}"
}

src_install() {
default
# Existing configuration file required to function
newconfd data/sysconfig.snapper snapper
prune_libtool_files
}

pkg_postinst() {
elog "In order to use Snapper, you need to set up"
elog "at least one config first. To do this, run:"
elog "snapper create-config <subvolume>"
elog "For more information, see man (8) snapper or"
elog "http://snapper.io/documentation.html"
}

0 comments on commit 193c338

Please sign in to comment.