Skip to content

Commit

Permalink
app-misc/recoll: bump to 1.31.2
Browse files Browse the repository at this point in the history
Signed-off-by: Punarbasu Purkayastha <[email protected]>
Closes: gentoo#22692
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
ppurka authored and juippis committed Nov 10, 2021
1 parent 4757e2b commit 199cdb9
Show file tree
Hide file tree
Showing 2 changed files with 136 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/recoll/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST recoll-1.27.12.tar.gz 3184471 BLAKE2B 60bcdee44259fa7f8b9decb9258ca0dae4edb
DIST recoll-1.28.5.tar.gz 3261816 BLAKE2B 6bf9daab0f97ee6fdb4033197d3fa3f4296b2df8a57566195fca3bf170fec621c27e7da00a1a5a8493fbbadca103a0db7b8c3051abe95d5c2aedb7c289c050a5 SHA512 df4c7a5e624933ccc7ce257a767a4621728a4dbcdd5b551b47845ed0fcffdd5a6f7f617a466404c5e8d8b62c81e57986e1f21e01d643899755623a2dc597d712
DIST recoll-1.29.2.tar.gz 3871580 BLAKE2B ae6ef5628dfac67a192a3d133d5b5d8ddec079ac79be2e8aa7e744669ed0478cb41628a0ed46b4ff2364823f367815b1eb4bca0a6e4b56a9e12d4f78c6842473 SHA512 c87fc054a0c34f1b6bcc10a4f2c84268a51df02b8ba84634c51f9396befe5b2b84fc93d363876158c9d117a164613e91d9c63b228fec5e0e07d234c97c4680c5
DIST recoll-1.31.0.tar.gz 3679099 BLAKE2B 6d02c0e0487ff02957ffc3c824152a14307e5a9ebfd472ffb84d047ce37f170ff7738b0d15ccfd6582840d22d19aa6e509ca50b98fd88d1a3730e58304cdb4b1 SHA512 1a740cdabab158737461ab8f097ece79844e1f0b64285871217049c0619df400d99db18eac8942e1986def555c5ab8364f3320eb403d150b061126cbc3be2116
DIST recoll-1.31.2.tar.gz 3689921 BLAKE2B 01eb0ef96362e214022a96876c10246c0d183a861c1e3d791717c3d77d4244ed90bbb9041bf23a613e59b5c099092c262d1bee1760ea527fe60f01383bec8a5f SHA512 365cc152715cb89c88b4271fdda4ccf963b1c6e3088f69684cba2a494bf9b0192e4553b1412607f3acd61ec85eb2fe92c46cd258b3fc2977f9528bb0a667e6cb
135 changes: 135 additions & 0 deletions app-misc/recoll/recoll-1.31.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,135 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8..10} )

inherit linux-info optfeature python-single-r1 qmake-utils systemd

DESCRIPTION="Personal full text search package"
HOMEPAGE="https://www.lesbonscomptes.com/recoll/"
SRC_URI="https://www.lesbonscomptes.com/recoll/${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="camelcase chm +inotify qt5 session +spell systemd webengine"
REQUIRED_USE="
session? ( inotify )
webengine? ( qt5 )
${PYTHON_REQUIRED_USE}
"

DEPEND="
dev-libs/xapian:=
sys-libs/zlib:=
virtual/libiconv
chm? (
dev-libs/chmlib
dev-python/pychm
)
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtprintsupport:5
webengine? ( dev-qt/qtwebengine:5[widgets] )
)
session? (
inotify? (
x11-libs/libSM
x11-libs/libICE
x11-libs/libX11
)
)
spell? ( app-text/aspell )
systemd? ( sys-apps/systemd )
${PYTHON_DEPS}
"

BDEPEND="
qt5? ( dev-qt/linguist-tools:5 )
"

RDEPEND="
${DEPEND}
app-arch/unzip
"

pkg_pretend() {
if has_version "<app-misc/recoll-1.20"; then
elog "Installing ${PV} over an 1.19 index is possible,"
elog "but there have been small changes in the way"
elog "compound words are indexed. So it is best to reset"
elog "the index. The best method to reset the index is to"
elog "quit all recoll programs and delete the index directory"
elog "rm -rf ~/.recoll/xapiandb, then start recoll or recollindex."
fi
}

pkg_setup() {
if use inotify; then
local CONFIG_CHECK="~INOTIFY_USER"
check_extra_config
fi
python-single-r1_pkg_setup
}

src_prepare() {
default
python_fix_shebang filters
}

src_configure() {
use qt5 && export QMAKE="$(qt5_get_bindir)/qmake"

local myeconfargs=(
$(use_enable camelcase)
$(use_enable chm python-chm)
$(use_enable session x11mon)
$(use_enable qt5 qtgui)
$(use_enable webengine)
$(use_with inotify)
$(use_with spell aspell)
$(use_with systemd)
--with-system-unit-dir="$(systemd_get_systemunitdir)"
--with-user-unit-dir="$(systemd_get_userunitdir)"
--disable-webkit
--without-fam
--enable-recollq
)

econf "${myeconfargs[@]}"
}

src_install() {
emake STRIP="$(type -P true || die)" DESTDIR="${D}" install
python_optimize

# html docs should be placed in /usr/share/doc/${PN}/html
dodoc -r "${ED}"/usr/share/recoll/doc/.
rm -r "${ED}/usr/share/recoll/doc" || die
find "${D}" -name '*.la' -delete || die
}

pkg_postinst() {
optfeature "XML based documents support" "dev-libs/libxslt[python] dev-libs/libxml2[python]"
optfeature "PDF files support" app-text/poppler
optfeature "PDF files with OCR support" app-text/tesseract
optfeature "MS Word files support" app-text/antiword
optfeature "Wordperfect files support" "app-text/libwpd[tools]"
optfeature "Lyx files support" app-office/lyx
optfeature "GNU Info files support" sys-apps/texinfo
optfeature "RAR archives support" dev-python/rarfile
optfeature "7zip archives support" dev-python/pylzma
optfeature "iCalendar files support" dev-python/icalendar
optfeature "Postscript files support" app-text/pstotext
optfeature "RTF files support" app-text/unrtf
optfeature "TeX files support" dev-text/detex
optfeature "DVI files support" virtual/tex-base
optfeature "DJVU files support" app-text/djvu
optfeature "tags in audio files support" media-libs/mutagen
optfeature "tags in image files support" media-libs/exiftool
optfeature "Midi karaoke files support" dev-python/chardet
}

0 comments on commit 199cdb9

Please sign in to comment.