Skip to content

Commit

Permalink
dev-util/rocminfo: 2.7.0 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.72, Repoman-2.3.17
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Aug 20, 2019
1 parent d7bd5c1 commit 1a3655e
Show file tree
Hide file tree
Showing 3 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/rocminfo/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST rocminfo-2.6.0.tar.gz 12293 BLAKE2B b08725b45f48e78841da9d6e57bb19a441a423e20f853d16024c620914059abf3cb2e61c12ae6fdfdb85eb3e984d488ae9975ab3fd2fcc529ecb576c6816fc92 SHA512 e2dae7e2e02b674b3ad959a3dffdcd8f550842edfd0eac5866259a6a12de1a5f935afbdcb37845fa189d0937c41186f0eb8be08e7b346ddef959d5dd7b62dca7
DIST rocminfo-2.7.0.tar.gz 12671 BLAKE2B 6cb6e2fa458224654f4b672d117e2a6c71c7d5aeed8ac71cf7ecddb76d9209f25596521b31465a94fde1c91744fc9bf68e637f7ff4f67a000cbfbe4793c5fa4b SHA512 ffdaa3d11d85475c7600c6b25d8eb7f90cbda13b820f33c250a7ac9b90f92d4d5352d8baee765b4bd3b9c7389b5ab6d3b87df77bf62d6696ed8cd96bfc6be1a0
23 changes: 23 additions & 0 deletions dev-util/rocminfo/files/rocminfo-2.7.0-sizeof.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
From cf96f42165fe76b98f653f979b4c182279dcac64 Mon Sep 17 00:00:00 2001
From: Wilfried Holzke <[email protected]>
Date: Fri, 16 Aug 2019 22:04:52 +0200
Subject: [PATCH] Fixed sizeof(err_val) to return the number of characters in
the array

---
rocminfo.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/rocminfo.cc b/rocminfo.cc
index 9fddcfb..ee20da8 100755
--- a/rocminfo.cc
+++ b/rocminfo.cc
@@ -72,7 +72,7 @@
char* err_str = NULL; \
if (hsa_status_string(err, \
(const char**)&err_str) != HSA_STATUS_SUCCESS) { \
- snprintf(&(err_val[0]), sizeof(err_val[12]), "%#x", (uint32_t)err); \
+ snprintf(&(err_val[0]), sizeof(err_val), "%#x", (uint32_t)err); \
err_str = &(err_val[0]); \
} \
printf("%shsa api call failure at: %s:%d\n", \
37 changes: 37 additions & 0 deletions dev-util/rocminfo/rocminfo-2.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
inherit git-r3
else
SRC_URI="https://github.com/RadeonOpenCompute/rocminfo/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/rocminfo-roc-${PV}"
fi

DESCRIPTION="ROCm Application for Reporting System Info"
HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"

RDEPEND="dev-libs/rocr-runtime"
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}/${PN}-2.6.0-cmake-variables.patch"
"${FILESDIR}/${P}-sizeof.patch"
)

src_configure() {
local mycmakeargs=(
-DROCM_DIR="${ESYSROOT}/usr"
-DROCR_INC_DIR="${ESYSROOT}/usr/include"
-DROCR_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
)
cmake-utils_src_configure
}

0 comments on commit 1a3655e

Please sign in to comment.